Bug 113958 - e1000 unreliable load after resume from ACPI sleep
Summary: e1000 unreliable load after resume from ACPI sleep
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-20 17:21 UTC by Bill Nottingham
Modified: 2014-03-17 02:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 18:36:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2004-01-20 17:21:20 UTC
Using acpi sleep to suspend-to-ram, on resume, I attempt to load
the e1000 driver.

This fails with:

Jan 19 19:18:26 nostromo kernel: Intel(R) PRO/1000 Network Driver -
version 5.2.20-k1
Jan 19 19:18:26 nostromo kernel: Copyright (c) 1999-2003 Intel
Corporation.
Jan 19 19:18:26 nostromo kernel: PCI: Enabling device 0000:02:01.0
(0000 -> 0003)
Jan 19 19:18:26 nostromo kernel: The EEPROM Checksum Is Not Valid
Jan 19 19:18:26 nostromo kernel: e1000: probe of 0000:02:01.0 failed
with error
-5

2.6.0-1.30, fwiw.

Comment 1 Bill Nottingham 2004-03-03 19:22:29 UTC
This behaves 'better' in 2.6.2-1.87, in that I only occasionally see
resume-from-suspend weirdness, instead of every time. (say, maybe one
of 10 times?)

Comment 2 Bill Nottingham 2004-03-24 16:40:21 UTC
Haven't seen this in a few weeks. Will reopen if it comes back.

Comment 3 Bill Nottingham 2004-03-24 16:40:47 UTC
Oh, wait. Haven't seen it because due to 4/4 I can't suspend and
resume. :)

Comment 4 Warren Togami 2004-04-16 09:52:12 UTC
Any different behavior with 2.6.5-1.326?

Comment 5 Bill Nottingham 2004-04-16 16:42:30 UTC
Haven't suspended enough to get a good handle. Will let you know in a
week or so. :/

Comment 6 Bill Nottingham 2004-05-03 18:36:38 UTC
Status is that there are enough other issues (airo driver *really*
doesn't like suspend, and doesn't unload correctly) that I haven't got
a chance to verify it. I can reopen if it comes back.


Note You need to log in before you can comment on or make changes to this bug.