Bug 113973 - up2date --channel=foo --installall does nothing
up2date --channel=foo --installall does nothing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 119071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 15:53 EST by Kevin Otte
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 23:47:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make installall work (372 bytes, patch)
2004-03-04 09:40 EST, Geoffrey D. Bennett
no flags Details | Diff

  None (edit)
Description Kevin Otte 2004-01-20 15:53:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
When I issue the command:
up2date --channel=helpdesk-ws3-laptop --installall
I get returned to a command prompt with no action having been taken.

Version-Release number of selected component (if applicable):
up2date-4.2.5-1

How reproducible:
Always

Steps to Reproduce:
1. run: up2date --channel=foo --installall
    

Actual Results:  Returned to command line, no action

Expected Results:  Retreival and installation of all packages in
requested channel.

Additional info:
Comment 1 Kevin Otte 2004-01-20 15:56:52 EST
up2date --showall --channel=foo is also broken.

At this point we have no way of installing all packages in a requested
channel.
Comment 2 Adrian Likins 2004-01-20 16:48:04 EST
fix is in up2date-4.2.7, whenever it becomes available.
Comment 3 Chip Turner 2004-01-20 17:01:13 EST
There are a few workarounds.  The easiest for most users is:

up2date --showall --show-channel | grep CHANNEL-LABEL | perl -lane
'print $F[0]' | xargs up2date
Comment 4 Kevin Otte 2004-01-20 17:34:40 EST
Actually, you still have to strip the version off $0.  The full
command would be something on the order of:

up2date $(up2date --showall --show-channel | grep CHANNEL-LABEL | perl
-lane 'print $F[0]'|sed -e 's/-[^-]*-[^-]*$//' | uniq)
Comment 6 Geoffrey D. Bennett 2004-03-04 09:40:12 EST
Created attachment 98293 [details]
patch to make installall work

After running into this bug, but before I went searching in bugzilla, I came up
with this patch.  It's trivial to manually apply if you don't like the
workaround already given.
Comment 7 Michael J. Carter 2004-03-10 13:16:18 EST
Any ETA on getting an errata out on this? The version that shipped w/
RHEL3 (up2date-4.0.1-1) didn't have this problem.

Comment 8 Adrian Likins 2004-03-22 16:34:09 EST
u2 update pack will have a fix for this. 
Comment 9 Adrian Likins 2004-03-30 18:14:34 EST
*** Bug 119071 has been marked as a duplicate of this bug. ***
Comment 10 John Flanagan 2004-05-11 23:47:37 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-138.html

Note You need to log in before you can comment on or make changes to this bug.