Bug 113974 - mdadm examine shows device state as dirty, no-errors
mdadm examine shows device state as dirty, no-errors
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mdadm (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-20 16:03 EST by Frank LeFevre
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 09:15:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank LeFevre 2004-01-20 16:03:01 EST
Description of problem: 
mdadm examine option against devices shoaw state as dirty, no-errors.

Version-Release number of selected component (if applicable):
mdadm-1.4.0-1

How reproducible:
Everytime

Steps to Reproduce:
1.mdadm -E /dev/sda1
2.
3.
  
Actual results:
/dev/sda1:
          Magic : a92b4efc
        Version : 00.90.00
           UUID : f0c893b0:dc28cd42:9caa9e9e:52b2c393
  Creation Time : Tue Jan 20 13:41:26 2004
     Raid Level : raid0
    Device Size : 3905408 (3.72 GiB 3.100 GB)
   Raid Devices : 9
  Total Devices : 9
Preferred Minor : 2

    Update Time : Tue Jan 20 13:41:26 2004
          State : dirty, no-errors
 Active Devices : 9
Working Devices : 9
 Failed Devices : 0
  Spare Devices : 0
       Checksum : e5d299ed - correct
         Events : 0.1

     Chunk Size : 128K

      Number   Major   Minor   RaidDevice State
this     0       8        1        0      active sync   /dev/sda1
   0     0       8        1        0      active sync   /dev/sda1
   1     1       8       17        1      active sync   /dev/sdb1
   2     2       8       33        2      active sync   /dev/sdc1
   3     3       8       49        3      active sync   /dev/sdd1
   4     4       8       65        4      active sync   /dev/sde1
   5     5       8       81        5      active sync   /dev/sdf1
   6     6       8       97        6      active sync   /dev/sdg1
   7     7       8      113        7      active sync   /dev/sdh1
   8     8       8      129        8      active sync   /dev/sdi1

Expected results:
According to the documentation, the state should be clean, no-errors.

Additional info:
Comment 1 Doug Ledford 2004-01-21 11:30:34 EST
This looks like you are performing the mdadm -E on the device while
the array is still live.  The array state is always dirty, no errors
until either an error occurs or the array is switched to readonly mode
or stopped completely.  The only time the state should be clean, no
errors is on a read-only or completely stopped array.

So, if you are seeing this on a currently running array, then please
close this bug report as NOTABUG and if the array is not running then
make note of that in this bug report.
Comment 2 Frank LeFevre 2004-01-23 15:28:13 EST
I was offsite yesterday at LinuxWorld and today our machine is down 
for hardware service. Will try as soon as it's back up. Thanks.
Comment 3 Frank LeFevre 2004-01-26 09:15:53 EST
Array was active. Once array was stopped, the display showed clean. 
Thanks.

Note You need to log in before you can comment on or make changes to this bug.