Bug 114008 - Mozilla breaks if you run epiphany as root
Mozilla breaks if you run epiphany as root
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 06:37 EST by Ian Laurie
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 16:26:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2004-01-21 06:37:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
If you run epiphany while logged in as root, when epiphany exits it
writes to /usr/lib/mozilla-1.4.1/components/compreg.dat and from that
point onwards Mozilla doesn't work fully.

Version-Release number of selected component (if applicable):
mozilla-1.4.1-18 and epiphany-1.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. Log in as root.
2. Launch epiphany, then exit.
3. Try to use Mozilla.
    

Actual Results:  Various things in Mozilla stop working.  Some
examples are the location bar stops remembering new URLs (though
existing ones stay there) and you can no longer download files
(clicking on stuff has no effect).

Expected Results:  Mozilla should not break after using epiphany.

Additional info:

You can fix Mozilla by reinstating the
/usr/lib/mozilla-1.4.1/components/compreg.dat file to the way it was
before you ran epiphany.

Redhat Linux 9 had the same problem exactly in that running galeon
toasted Mozilla.

Since epiphany can run with the compreg.dat file as is, why have it
write to the file at all?  If non root users run ephiphany, it *can't*
write to the file anyhow.
Comment 1 Christopher Blizzard 2004-02-12 13:59:26 EST
Epiphany adds to the internal list of components and writes it out to
disk when it exits.

Sigh.
Comment 2 Zack Cerza 2004-07-22 12:44:11 EDT
Running current Rawhide, I can't reproduce this. I tested all the
things that you reported to be broken after running epiphany as root,
then mozilla as both root and a user.
/usr/lib/mozilla-1.7/components/compreg.dat wasn't written to.

Does this problem still exist in FC2?
Comment 3 Christopher Blizzard 2004-07-22 16:26:27 EDT
Not that I know of.  Marking CURRENTRELEASE.
Comment 4 Ian Laurie 2004-07-27 01:21:22 EDT
Sorry for the delay in responding.

I cannot reproduce this bug in FC2.  Looks like Epiphany doesn't write
out to the compreg.dat file any longer.


Note You need to log in before you can comment on or make changes to this bug.