Bug 114035 - Using a non-SELinux kernel possibly causing id spewage?
Summary: Using a non-SELinux kernel possibly causing id spewage?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-21 18:47 UTC by Tim Powers
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 14:19:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Powers 2004-01-21 18:47:54 UTC
We created a chroot environment to run mass rebuild tests for the
current devel stream for what will eventually become Test 1 for FC2.

The main OS installed outside of the chroot is RHEL 3 U1. 

When I chroot into the chrooted environment I see these messages:

[root@loki rebuildtest]# /usr/sbin/chroot .
id: can't get process context
id: can't get process context
id: can't get process context
bash: [: too many arguments
[root@loki /]#

Now, this may be /proc not being mounted or something else odd, I'm
not sure. Elliot said there's a bug WRT SELinux and coreutils, so I'm
filing this through his recommendation and setting the owner to dwalsh.

Comment 1 Daniel Walsh 2004-01-21 19:28:29 UTC
This is caused by a change in the definition of is_selinux_enabled. 
This used to be a boolean function, but now it returns >0 if enabled 0
if not enabled and -1 if unknown.  IE /proc not mounted.  Most of the
SELinux code is written expecting the boolean.  I have rewritten the
coreutils patch to fix this problem.  I need to look at other kits to
see what the correct thing to do is.

Dan

Comment 2 Daniel Walsh 2004-02-11 14:19:02 UTC
Fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.