Bug 114041 - Yum does not support SELinux file_contexts via rpm
Yum does not support SELinux file_contexts via rpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 14:38 EST by Daniel Walsh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-31 06:38:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2004-01-21 14:38:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
yum update never sets file contexts properly when updating packages,
regardless of whether
/etc/security/selinux/src/policy/file_contexts/file_contexts exist.


Version-Release number of selected component (if applicable):
yum-2.0.4-5

How reproducible:
Always

Steps to Reproduce:
1.yum update
2.check file context
3.
    

Actual Results:  File contexts not set

Expected Results:  File Contexts set

Additional info:
Comment 1 Jeff Johnson 2004-01-31 06:38:50 EST
Fixed in rpm-4.3-0.9.1 and later afaik.

Note You need to log in before you can comment on or make changes to this bug.