Bug 114045 - connecting to an ntp server fails
connecting to an ntp server fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 15:16 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 09:49:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ntp configuration file (2.79 KB, text/plain)
2004-01-22 15:17 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2004-01-21 15:16:58 EST
Description of problem:
connecting to an ntp server fails

Version-Release number of selected component (if applicable):

ntpd 4.1.2@1.892 Wed Oct 29 06:06:59 EST 2003 (1)

How reproducible:
always trying to change the time

Steps to Reproduce:
1.redhat-config-date
2.select network time protocol sync.
3.
  
Actual results
No change, /var/log/messages states

Jan 21 21:17:53 localhost ntpdate[7115]: no server suitable for
synchronization found
Jan 21 21:17:53 localhost ntpd:  failed
Jan 21 21:17:53 localhost ntpd[7119]: ntpd 4.1.2@1.892 Wed Oct 29
06:06:59 EST 2003 (1)
Jan 21 21:17:53 localhost ntpd[7119]: precision = 16 usec
Jan 21 21:17:53 localhost ntpd[7119]: kernel time discipline status 0040
Jan 21 21:17:53 localhost ntpd[7119]: frequency initialized 0.000 from
/var/lib/ntp/drift
Jan 21 21:17:53 localhost ntpd: Avvio ntpd succeeded



Expected results:

Time in sync, different log 

Additional info:
Comment 1 Harald Hoyer 2004-01-22 04:45:25 EST
please attach /etc/ntp.conf
Comment 2 Need Real Name 2004-01-22 15:17:42 EST
Created attachment 97194 [details]
ntp configuration file

# Prohibit general access to this service.
restrict default ignore
restrict 66.187.233.4 mask 255.255.255.255 nomodify notrap noquery

# Permit all access over the loopback interface.  This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1


# -- CLIENT NETWORK -------
# Permit systems on this network to synchronize with this
# time service.  Do not permit those systems to modify the
# configuration of this service.  Also, do not use those
# systems as peers for synchronization.
# restrict 192.168.1.0 mask 255.255.255.0 notrust nomodify notrap


# --- OUR TIMESERVERS -----
# or remove the default restrict line
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.

# restrict mytrustedtimeserverip mask 255.255.255.255 nomodify notrap noquery
# server mytrustedtimeserverip



# --- NTP MULTICASTCLIENT ---
#multicastclient			# listen on default 224.0.1.1
# restrict 224.0.1.1 mask 255.255.255.255 notrust nomodify notrap
# restrict 192.168.1.0 mask 255.255.255.0 notrust nomodify notrap



# --- GENERAL CONFIGURATION ---
#
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
server 66.187.233.4
fudge	127.127.1.0 stratum 10	

#
# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
#
driftfile /var/lib/ntp/drift
broadcastdelay	0.008

#
# Authentication delay.  If you use, or plan to use someday, the
# authentication facility you should make the programs in the auth_stuff
# directory and figure out what this number should be on your machine.
#
authenticate yes

#
# Keys file.  If you want to diddle your server at run time, make a
# keys file (mode 600 for sure) and define the key number to be
# used for making requests.
#
# PLEASE DO NOT USE THE DEFAULT VALUES HERE. Pick your own, or remote
# systems might be able to reset your clock at will. Note also that
# ntpd is started with a -A flag, disabling authentication, that
# will have to be removed as well.
#
keys		/etc/ntp/keys
Comment 3 Need Real Name 2004-01-22 15:20:01 EST
I have tryed a lot of ntp servers and no one is ok.

Bye

Note You need to log in before you can comment on or make changes to this bug.