Bug 114058 - RPM Segmentation fault
RPM Segmentation fault
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-21 18:59 EST by Dennis Chandler
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 08:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Chandler 2004-01-21 18:59:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Upgrading the gcc compiler and libraries on RedHat 7.2 (kernel 2.4.20-
28-7smp) breaks rpm, rpm now segfaults when you do a rpm -ivh .... 

Upgrades done:
          From            To
gcc       2.96            3.2.3
bintils   2.11.90.0.8-12  2.13.2
glibc     2.2.4-13        2.3.2

I know this isn't a bug, but how do I get rpm working again?
Any help would appreciated. 

dchandler@xiran.com



Version-Release number of selected component (if applicable):
rpm version 4.04

How reproducible:
Always

Steps to Reproduce:
1.rpm -ivh <any-rpm>
2.
3.
    

Actual Results:  rpm -ivh ganglia-monitor-core-2.5.0-1.i386.rpm
Preparing...                
########################################### [100%]
Segmentation fault


Additional info:
Comment 1 Jeff Johnson 2004-01-25 22:29:26 EST
A --rebuilddb with rpm-4.1.1 or later will probably fix.

Try installing that version (from ftp.rpm.org) using rpm2cpio.

Does that fix?
Comment 2 Dennis Chandler 2004-01-26 19:16:54 EST
Worked great.  Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.