Bug 114130 - LESSOPEN env var breaks normal less functionality
LESSOPEN env var breaks normal less functionality
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: less (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-22 16:43 EST by Robert M. Riches Jr.
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 04:34:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M. Riches Jr. 2004-01-22 16:43:27 EST
Description of problem:
Normal less functionality (cbreak mode to be precise) is
broken by the LESSOPEN environment variable pointing to
/usr/bin/lessopen.sh (okay, to a pipeline involving said
script).

Version-Release number of selected component (if applicable):
less-378-7

How reproducible:
100%

Steps to Reproduce:
1. Create or find a file containing more than one page of
   plain text.  The output of 'lspci -v' may suffice.

2. Run less on that file, from a terminal window or equivalent.

3. After the first screenfull is visible, press the spacebar.
  
Actual results:
The space character is echoed, but the next screenful of
text is not displayed.

Expected results:
The next screenful of text should be displayed.

Additional info:
Unsetting environment variable LESSOPEN appears to be a
workaround.
Comment 1 Karsten Hopp 2004-01-28 05:32:24 EST
I cannot reproduce this with LANG=de_DE.UTF-8 or LANG=en_US.UTF-8 
and less-381. 
Which locale are you using and ? 
Comment 2 Robert M. Riches Jr. 2004-01-28 20:01:40 EST
I'm using LANG=en_US.UTF-8.

What's really strange is I can't reproduce it now, either.
I thought I had tested it on multiple terminals to make sure
it wasn't just a hosed xterm (from somebody emailing characters
above 0x7f) that was causing the symptom.

You are welcome to mark this as "not a bug" and "customer
was mistaken".  Sorry for the false alarm.
Comment 3 Karsten Hopp 2004-01-29 04:34:22 EST
closing. Please reopen when you find a way to reproduce this.
Comment 4 Robert M. Riches Jr. 2004-02-06 21:11:12 EST
Okay, I found a way to reproduce it, when I do
"less /etc/gconf/schemas/gnome-session.schemas" with the
default LESSOPEN value, cbreak appears off, as in the
spacebar is echoed, not acted on.  This is with LANG set
to en_US.UTF-8.  Unsetting LESSOPEN makes less behave
properly, as in the space bar works.

I would guess it's tied to the non-ASCII, maybe multi-byte
characters in the file, along with the LESSOPEN variable.

Note You need to log in before you can comment on or make changes to this bug.