Bug 114143 - anaconda Python traceback while reading Update 3 disc2 (CD install everything)
anaconda Python traceback while reading Update 3 disc2 (CD install everything)
Status: CLOSED DUPLICATE of bug 112776
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-22 20:27 EST by Tim Chambers
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Chambers 2004-01-22 20:27:50 EST
How do I specify 2.1u3 in this form? This is NOT 2.1. I'm using the
2.1 Update 3 CD set.

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031107 Debian/1.5-3

Description of problem:
Seen while on Everest Madison, reproduced on Everest McKinley.
mediacheck passed for all CDs I used. Cannot complete the install.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run(self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.ph", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 145, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 611, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 244, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 86, in getFilename
    isys.umount("/mnt/source")
  File "/usr/lib/anaconda/isys.py", line 170, in umount
    rc = _isys.umount(what)
SystemError: (1, 'Device or resource busy')


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
install everything via CD on the VGA console


Actual Results:  see description

Expected Results:  Should be able to complete the install.

Additional info:
Comment 1 Tim Chambers 2004-01-23 12:18:41 EST
D'oh. If I had searched the right product database I would've seen
that Glen already reported this.

*** This bug has been marked as a duplicate of 112776 ***
Comment 2 Tim Chambers 2004-01-23 12:20:21 EST
(Just closing the loop.) D'oh. If I had searched the right product
database I would've seen that Glen already reported this.
Comment 3 Tim Chambers 2004-01-23 12:21:33 EST
d'oh
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.