Bug 114147 - copy/paste large text document fails with Klipper
copy/paste large text document fails with Klipper
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-22 21:41 EST by Ben Smith
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-23 12:25:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Smith 2004-01-22 21:41:06 EST
Description of problem:
Copying large text between several different applications fails with
Klipper running, mainly OpenOffice, Mozilla, and KWrite/Edit.

Version-Release number of selected component (if applicable):
qt-3.1.2-14

How reproducible:
Very.

Steps to Reproduce:
1.  Make sure Klipper is running.
2.  Open a large (>2 pages) document in OpenOffice Writer.
3.  Open a blank document in KWrite/Edit.
4.  Copy the document from OOo and paste in KWrite/Edit
  
Actual results:
Sometimes it doesn't work at all.  Most of the time just the first few
paragraphs get copied.

Expected results:
The entire selection should be copied.

Additional info:
I can't tell a difference whether I use the Copy/Paste commands or
select/middle-click.

This works fine on a system that was upgraded to KDE 3.2 beta 2 and
whatever version of QT that requires.

From scanning mailing lists, the consensus seems to be that this is
related to QT's 'QClipboard' and was fixed in recent releases.

As a workaround, I have disabled Klipper and am using XClipboard. 
That is not a very viable solution since it doesn't run in the panel
and doesn't seem to have support for italics/bold/tabs, etc.
Comment 1 Ngo Than 2004-01-23 12:25:50 EST
yes, it's fixed in new qt-3.2.3/kde 3.2 Beta2, which is available for
FC1 on ftp.kde.org.
Comment 2 Ben Smith 2004-01-23 14:44:39 EST
I guess the only reason I wasn't using that is that, last time I
looked, redhat-artwork didn't work with the newest version.  I'll give
it a try.  Here's a link if anyone's interested: 
ftp://ftp.kde.org/pub/kde/unstable/3.1.94/RedHat/Fedora/i386

Note You need to log in before you can comment on or make changes to this bug.