This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 114170 - rpm doesn't seem to work over http
rpm doesn't seem to work over http
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 11:09 EST by Bill Peck
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 13:12:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2004-01-23 11:09:27 EST
Description of problem:

When running rawhide from 0120 rpm doesn't seem to work over http.
The following command fails
rpm -qp http://stp.boston.redhat.com/bosqa/stp-client.noarch.rpm

with this error:
error: http://stp.boston.redhat.com/bosqa/stp-client.noarch.rpm: MD5
digest: BAD Expected(64fe76d6d1d5bfa680126fb2d68c9b87) !=
(a211ca1b276fb2ae075bd7c7dccd1694)

but if I get the file with wget it and use the local rpm it works.


Version-Release number of selected component (if applicable):
rpm-4.3-0.7.1

How reproducible:
everytime

Steps to Reproduce:
1. install rawhide from 0120
2. see above
3.
  
Actual results:


Expected results:


Additional info:
SELinux is in nonenforcing mode.
Comment 1 Jeff Johnson 2004-01-23 22:00:20 EST
Hmmm, WORKSFORME:
$ sudo rpm -Uvh
http://mirror.dulug.duke.edu/pub/fedora/linux/core/development/i386/Fedora/RPMS/wget-1.9.1-3.i386.rpm
WARNING: Multiple same specifications for /var/lib/dhcp(3)?.
Retrieving
http://mirror.dulug.duke.edu/pub/fedora/linux/core/development/i386/Fedora/RPMS/wget-1.9.1-3.i386.rpm
Preparing...               
########################################### [100%]
   1:wget                  
########################################### [100%]

Add --nodigest to disable the md5 verify, that might help.
Comment 2 Bill Peck 2004-01-26 09:38:34 EST
I can run the command you have above as well.  Thats not where I have
a problem.  The problem is with -q not -U.

if I turn digest mode off it does work correctly but I don't see that
as a solution.  This should work.
Comment 3 Jeff Johnson 2004-01-26 13:12:09 EST
I ran queries as well.

http support in rpm is minimal, and low priority, no matter what.

Either live with --nodigest/wget, or get a fix for my 2 feeble
printf's that drive http within rpm onto rpm's road map somehow.
Comment 4 Bishop Clark 2004-06-15 22:54:53 EDT
Hey Jeff,

How do we get a fix in there?  You mean hack it up ourselves?  I'm
curious as to just what happened to knock even the minimal http
support - which was completely acceptable before, even if you figure
it was minimal - out of rpm in this version.  I use rpm -V with http a
lot more than the next guy, and it's actually what caused me to move
to RH from Slackware oh, so long ago.  It's a definite life-saver,
imho, and I love showing it off (ignoring some %vrfy false-positive
noise).

FWIW, I can't even use rpm -U http://etc from FC2;  I'd grudgingly
live with no -qp http support, but busted -U http support was a
definite itch the other night while setting up a buddy's FC2 sohogw
box.  Right now I'm working around it with apt (which of course works
around it with a get before -U), but the potential loss of -V with
http would eventually bite me when I most need to verify vs a
remotely-located RPM.

Can we perhaps reopen:Low/Enh this one?

Note You need to log in before you can comment on or make changes to this bug.