Bug 11420 - [netatalk] free disk space reported incorrectly to clients
[netatalk] free disk space reported incorrectly to clients
Product: Red Hat Powertools
Classification: Retired
Component: hfsutils (Show other bugs)
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
Depends On:
  Show dependency treegraph
Reported: 2000-05-15 12:34 EDT by David Thorpe
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-06-20 14:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Thorpe 2000-05-15 12:34:55 EDT
free disk space is reported incorrectly to clients, probably due
to netatalk not being entirely 64 bit clean. patch might need
to be applied to RPM:


also, I sometimes get MacOS 8 clients disconnecting from server during
file transfer and then creating huge files on the server side, until
all disk space fills up. I believe this is fixed in newer asun
patches, could these patches also be applied to the RPM?

Best wishes, David Thorpe
Comment 1 David Thorpe 2000-05-15 12:54:59 EDT
Found this in README.ASUN, is it relevant?

ADDITIONAL NOTE: gcc sometimes has problems with 64-bit ints. if you get
inaccurate volume sizes, compile etc/afpd/volume.c without optimization.
Comment 2 David Thorpe 2000-05-16 05:21:59 EDT
This morning I recompiled afpd
from the netatalk package with optimization off when compiling volume.c
(ie, I did a gcc without -O2) and it worked a treat. So I think there's
probably some strange gcc optimizations with this file.
Comment 3 David Thorpe 2000-05-16 05:22:59 EDT
Regarding the other problem (Mac client starts to copy file
over, then disconnects, and then server continues to create a huge garbage
file until all disk space used up) here is a mail on the netatalk mailing

Comment 4 Tim Powers 2000-06-20 14:56:34 EDT
I can't ship the 2.1.4 stuff since asun explicitly has requested distros not do
that until it has been declared stable.

The other problem concerning -O2 has been solved though. It should show up in
rawhide shortly.


Note You need to log in before you can comment on or make changes to this bug.