Bug 114204 - UDCT: Required fields aren't enforced in UI, causes FlushException
UDCT: Required fields aren't enforced in UI, causes FlushException
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: content types (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 18:05 EST by Jon Orris
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 10:46:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2004-01-23 18:05:36 EST
Description of problem:
@39693
If there is a required field on a UDCT that isn't filled out on
creation, a FlushException will occur. The UI does not enforce the
field being required.


CCM issue report code: 172.16.64.111:c96746:fa44f881f1

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: 172.16.64.111:c96746:fa44f881f1 -*-*-*-
-*-*-*- Message 1: com.arsdigita.persistence.FlushException: null
(root cause: Unable to send all events to database for object
[com.arsdigita.cms.contenttypes.Snerk:{id=9018}] because these
required properties are null:
 [com.arsdigita.cms.contenttypes.Snerk:{id=9018}].Blah) -*-*-*-
-*-*-*- Message 2: com.redhat.persistence.FlushException: Unable to
send all events to database for object
[com.arsdigita.cms.contenttypes.Snerk:{id=9018}] because these
required properties are null:
 [com.arsdigita.cms.contenttypes.Snerk:{id=9018}].Blah -*-*-*-

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: System properties -*-*-*-
ccm.home: /var/ccm-devel/web/jorris/rickshaw
com.arsdigita.util.Assert.enabled: true
file.encoding: UTF-8
file.encoding.pkg: sun.io
file.separator: /
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.print.PSPrinterJob
java.class.path:
/home/boston/jorris/dev/lib/classes12.zip:/usr/share/java/junit.jar:/opt/oracle/product/9.2.0.1/jdbc/lib/classes12.zip:/usr/share/java/servletapi4.jar:/opt/oracle/product/9.2.0.1/jdbc/lib/classes12.zip:/opt/resin/2.1.4/lib/jaxp.jar:/opt/resin/2.1.4/lib/dom.jar:/opt/resin/2.1.4/lib/jdbc2_0-stdext.jar:/opt/resin/2.1.4/lib/jdbc-mysql.jar:/opt/resin/2.1.4/lib/jndi.jar:/opt/resin/2.1.4/lib/jmx.jar:/opt/resin/2.1.4/lib/jta-spec1_0_1.jar:/opt/resin/2.1.4/lib/resin.jar:/opt/resin/2.1.4/lib/sax.jar:/opt/resin/2.1.4/lib/webutil.jar:/usr/java/j2sdk1.4.2_03/lib/tools.jar:/usr/java/j2sdk1.4.2_03/jre/lib/rt.jar:/opt/resin/2.1.4/lib/jsdk23.jar
java.class.version: 48.0
java.endorsed.dirs: /usr/java/j2sdk1.4.2_03/jre/lib/endorsed
java.ext.dirs:
/usr/java/j2sdk1.4.2_03/jre/lib/ext:/usr/java/j2sdk1.4.2_03/lib/ext:/var/ccm-devel/web/jorris/rickshaw/webapps/WEB-INF/system:/usr/share/ccm-tools/lib/security
java.home: /usr/java/j2sdk1.4.2_03/jre
java.io.tmpdir: /tmp
java.library.path:
/usr/java/j2sdk1.4.2_03/jre/lib/i386/client:/usr/java/j2sdk1.4.2_03/jre/lib/i386:/usr/java/j2sdk1.4.2_03/jre/../lib/i386:/opt/oracle/product/9.2.0.1/lib:/lib:/usr/lib:/usr/local/lib:libexec
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.4.2_03-b02
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.4
java.util.prefs.PreferencesFactory:
java.util.prefs.FileSystemPreferencesFactory
java.vendor: Sun Microsystems Inc.
java.vendor.url: http://java.sun.com/
java.vendor.url.bug: http://java.sun.com/cgi-bin/bugreport.cgi
java.version: 1.4.2_03
java.vm.info: mixed mode
java.vm.name: Java HotSpot(TM) Client VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: Sun Microsystems Inc.
java.vm.version: 1.4.2_03-b02
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory:
org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
com.icl.saxon.TransformerFactoryImpl
line.separator: 

log4j.configuration:
file:///var/ccm-devel/web/jorris/rickshaw/conf/log4j.properties
os.arch: i386
os.name: Linux
os.version: 2.4.21-9.EL
path.separator: :
resin.home: /opt/resin/2.1.4
sun.arch.data.model: 32
sun.boot.class.path:
/usr/java/j2sdk1.4.2_03/jre/lib/rt.jar:/usr/java/j2sdk1.4.2_03/jre/lib/i18n.jar:/usr/java/j2sdk1.4.2_03/jre/lib/sunrsasign.jar:/usr/java/j2sdk1.4.2_03/jre/lib/jsse.jar:/usr/java/j2sdk1.4.2_03/jre/lib/jce.jar:/usr/java/j2sdk1.4.2_03/jre/lib/charsets.jar:/usr/java/j2sdk1.4.2_03/jre/classes
sun.boot.library.path: /usr/java/j2sdk1.4.2_03/jre/lib/i386
sun.cpu.endian: little
sun.cpu.isalist: 
sun.io.unicode.encoding: UnicodeLittle
sun.java2d.fontpath: 
sun.os.patch.level: unknown
user.country: US
user.dir: /opt/resin/2.1.4
user.home: /home/boston/jorris
user.language: en
user.name: jorris
user.timezone: America/New_York
waf.workflow.simple.alerts_enabled: true

-*-*-*- Section: Stack trace -*-*-*-
com.redhat.persistence.FlushException: Unable to send all events to
database for object [com.arsdigita.cms.contenttypes.Snerk:{id=9018}]
because these required properties are null:
 [com.arsdigita.cms.contenttypes.Snerk:{id=9018}].Blah
	at com.redhat.persistence.Session.assertFlushed(Session.java:471)
	at
com.arsdigita.persistence.DataObjectImpl.assertFlushed(DataObjectImpl.java:435)
	at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:418)
	at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
	at
com.arsdigita.cms.ui.authoring.PageCreateDynamic.process(PageCreateDynamic.java:551)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:490)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:464)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:494)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:356)
	at com.arsdigita.bebop.Form.process(Form.java:440)
	at com.arsdigita.bebop.MetaForm.process(MetaForm.java:160)
	at com.arsdigita.bebop.Form.respond(Form.java:281)
	at com.arsdigita.bebop.PageState.respond(PageState.java:370)
	at com.arsdigita.bebop.Page.process(Page.java:714)
	at com.arsdigita.bebop.Page.process(Page.java:686)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:758)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:281)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:80)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:75)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:296)
	at
com.arsdigita.cms.dispatcher.ContentCenterDispatcher.dispatch(ContentCenterDispatcher.java:146)
	at
com.arsdigita.sitenode.SiteNodeDispatcher.doDispatch(SiteNodeDispatcher.java:432)
	at
com.arsdigita.sitenode.SiteNodeDispatcher.access$100(SiteNodeDispatcher.java:83)
	at
com.arsdigita.sitenode.SiteNodeDispatcher$1.excurse(SiteNodeDispatcher.java:263)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.sitenode.SiteNodeDispatcher.dispatch(SiteNodeDispatcher.java:249)
	at
com.arsdigita.dispatcher.BaseDispatcherServlet.service(BaseDispatcherServlet.java:363)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at
com.caucho.server.http.QNamedDispatcher.forward(QNamedDispatcher.java:157)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:199)
	at
com.arsdigita.web.DispatcherServlet.doService(DispatcherServlet.java:141)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:176)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:147)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:291)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at
com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:534)


-*-*-*- Section: HTTP headers -*-*-*-
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept-Encoding: gzip,deflate
Accept-Language: en-us,en;q=0.5
Connection: keep-alive
Content-Length: 1800
Content-Type: multipart/form-data;
boundary=---------------------------463892522145696273720675546
Cookie: JSESSIONID=abIKF7DPBIQg;
ad_user_login=2003!1169506938033!a2DL6mwuH/Ex4XCA9ct06w==
Host: goodeats:9004
Keep-Alive: 300
Referer: http://goodeats:9004/ccm/content-center/
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

-*-*-*- Section: Servlet attributes -*-*-*-
com.arsdigita.bebop.PageState: com.arsdigita.bebop.PageState@ad782e = {
m_page = com.arsdigita.cms.ui.WorkspacePage@115584c,
m_request = com.arsdigita.dispatcher.MultipartHttpServletRequest@ed99c9,
m_response = com.caucho.server.http.HttpResponse@ad3d63,
m_pageState = com.arsdigita.bebop.FormData@199457f = {
m_parameterDataValues = {bbp.41.sel={null, []}, bbp.23.col={null, []},
g11n.enc={UTF-8, []}, bbp.57.sel={null, []}, bbp.37.ps={15, []},
bbp.3.pane={0, []}, bbp.i={{8, 14, 18}, []}, type_id={10001, []},
bbp.e={null, []}, bbp.v={null, []}, section_id={1012, []},
bbp.4.f={1008, []}, sortType={null, []}, bbp.s={13, []},
sortDirection={null, []}, lockFilterType={null, []}, bbp.23.row={null,
[]}, bbp.13.bid={null, []}, page={null, []}, bbp.15.sectionId={1012,
[]}, single_type={null, []}, bbp.13.iid={9018, []}},
m_formErrors = null,
m_model = com.arsdigita.bebop.FormModel@1a1a614,
m_locale = en_US,
m_isTransformed = true,
m_isValid = false,
m_isSubmission = true
},
m_attributes = null,
,
m_grabbingComponent = null,
m_invisible = {5, 9, 10, 11, 14, 15, 18, 38, 47}
}
com.arsdigita.bebop.RequestLocal:
{com.arsdigita.kernel.ui.ACSObjectSelectionModel$1@ad972d=true,
com.arsdigita.bebop.Form$2@1952e89=,
com.arsdigita.kernel.ui.ACSObjectSelectionModel$1@2f784b=true,
com.arsdigita.bebop.MetaForm$1@10f2591=com.arsdigita.bebop.Form@19e96f7
[pageCreate,null,post,false]}
com.arsdigita.dispatcher.OriginalRequest:
com.caucho.server.http.HttpRequest@1ffaf22
com.arsdigita.dispatcher.RequestContext:
com.arsdigita.sitenode.SiteNodeRequestContext@1ade18b
com.arsdigita.dispatcher.RequestValue:
{com.arsdigita.dispatcher.RequestValue@837311=null}
com.arsdigita.dispatcher.WrappedRequest:
com.arsdigita.dispatcher.MultipartHttpServletRequest@14981e0
com.arsdigita.kernel.ACSObject:1008: [com.arsdigita.cms.Folder:{id=1008}]
com.arsdigita.kernel.ACSObject:9018:
[com.arsdigita.cms.contenttypes.Snerk:{id=9018}]
com.arsdigita.web.BaseServlet.request_url:
/ccm/content-center/?g11n.enc=UTF-8&save=%C3%82%C2%A0%C3%82%C2%A0%C3%82%C2%A0Create%C3%82%C2%A0%C3%82%C2%A0%C3%82%C2%A0&title=grick&bbp.37.ps=15&bbp.3.pane=0&bbp.i=d0.8.1.5.1.3.1&type_id=10001&section_id=1012&bbp.4.f=1008&language=en&bbp.s=13&Blah=&bbp.15.sectionId=1012&form.pageCreate=visited&name=grick
com.arsdigita.web.DispatcherServlet.falling_back: true

-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/content-center/
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: abIKF7DPBIQg (expires: -1)
ad_user_login: 2003!1169506938033!a2DL6mwuH/Ex4XCA9ct06w== (expires: -1)
-*-*-*-*-*- End Error Report -*-*-*-*-*-

Note You need to log in before you can comment on or make changes to this bug.