Bug 114222 - ATI Radeon 9600 Pro card not properly detected, freezes the X
ATI Radeon 9600 Pro card not properly detected, freezes the X
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-24 12:05 EST by Alexander L. Belikoff
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 19:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander L. Belikoff 2004-01-24 12:05:33 EST
Description of problem:

ATI Radeon 9600 Pro 128 Mb DDR 8x AGP (mfg part no. 100-437002) is not
identified by lspci.

Brief lspci output:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown
device 4150
01:00.1 Display controller: ATI Technologies Inc: Unknown device 4170

Detailed output follows:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown
device 4150 (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc: Unknown device 0002
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 255 (2000ns min), cache line size 04
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at c000 [size=256]
	Region 2: Memory at fe9f0000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at fe9c0000 [disabled] [size=128K]
	Capabilities: <available only to root>
00: 02 10 50 41 07 01 b0 02 00 00 00 03 04 ff 80 00
10: 08 00 00 e0 01 c0 00 00 00 00 9f fe 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 10 02 00
30: 00 00 9c fe 58 00 00 00 00 00 00 00 0a 01 08 00

01:00.1 Display controller: ATI Technologies Inc: Unknown device 4170
	Subsystem: ATI Technologies Inc: Unknown device 0003
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 64 (2000ns min), cache line size 04
	Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 1: Memory at fe9e0000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: <available only to root>
00: 02 10 70 41 07 00 b0 02 00 00 80 03 04 40 00 00
10: 08 00 00 d0 00 00 9e fe 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 10 03 00
30: 00 00 00 00 50 00 00 00 00 00 00 00 ff 00 08 00

Furthermore, manually selecting the proper card in
redhat-config-xfree86 causes system lock-ups in a random fashion.

Version-Release number of selected component (if applicable):

n/a

How reproducible:

highly reproducible, unfortunately :-(

Steps to Reproduce:
1. Start redhat-config-xfree86
2. Select proper videocard
3. Click on the color depth button
4. Try clicking on 'millions of colors'

Actual results:

System locks up (even Caps Lock light doesn't work)

Expected results:

System works flawlessly, entertains the user with latest advances in
computer graphics :-)

Additional info:

n/a
Comment 1 Nigel Metheringham 2004-03-28 14:52:52 EST
Duplicate of bug #109840
Comment 2 Mike A. Harris 2004-10-09 19:24:48 EDT
Radeon 9200/9600/9800, and the Pro, SE, and XT variants of these
are now officially supported in Fedora Core 2 and later OS releases.

Once you've upgraded to Fedora Core 2 or later, this hardware should
be automatically detected and configured.  If you experience problems
with the "radeon" driver in Fedora Core 2, please file a bug report
in the X.Org bugtracker located at http://bugs.freedesktop.org in
the "xorg" component.

Setting status to "CURRENTRELEASE"



Note You need to log in before you can comment on or make changes to this bug.