Bug 114237 - xchat 2.0.4 on x86_64 has 64-bit issues (patch)
xchat 2.0.4 on x86_64 has 64-bit issues (patch)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-24 22:48 EST by Peter Zelezny
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 07:27:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Zelezny 2004-01-24 22:48:12 EST
This patch fixes some 64-bit bugs:

http://xchat.org/files/source/2.0/patches/xc205-fix64bit.diff

Although it's for 2.0.5, it applies okay to 2.0.4 aswell.
Comment 1 Mike A. Harris 2004-01-26 09:14:39 EST
Great, thanks Peter!  I'll add that to CVS so it gets into future
updates.

Is this patch integrated into 2.0.7 I assume?
Comment 2 Peter Zelezny 2004-01-26 09:57:39 EST
Yes it's in 2.0.5+, but I thought it might be a good idea for the
AMD64 release, which still has 2.0.4 (according to my local mirror).
Comment 3 Mike A. Harris 2004-01-26 12:04:52 EST
Ok, cool.  I was just wondering if it was something I should add to
rawhide as well or not.  Once our first alpha/beta of Fedora Core 2
goes out the door, I might update to 2.0.7 on Fedora and RHL 9 perhaps
if the test results too.

I noticed some 64bit problems on Alpha in xchat a long time ago, but
intended on debugging them myself and never got around to it.  I'll
have to whip up an Alpha build as well, and give it a shot.  I'll also
test on ppc64, s390x, and ia64.

Thanks again,
TTYL
Comment 4 Mike A. Harris 2004-02-17 01:59:23 EST
This is fixed in Fedora development now by updating to xchat-2.0.7
a while back.  I don't know how to update this package for
Fedora Core 1/AMD64 however as we haven't released an official
release for that, and the engineering effort is somewhat disjoint
from our standard internal procedures.

I've carbon copied the person who is doing most of the AMD64
volunteerwork, in hopes he can comment, and we can coordinate
to ensure this is fixed in the FC1/AMD64 release also.

Justin:  Can you comment?  Would an xchat-2.0.7 update for
Fedora Core 1 do the trick perhaps?

TIA
Comment 5 Justin M. Forbes 2004-02-17 10:28:55 EST
I will try to get 2.0.7 pushed as an update for the FC1 AMD64 release
today.  Thanks guys 
Comment 6 Mike A. Harris 2004-02-19 07:27:07 EST
I have released a test update for FC1 of xchat 2.0.7, which
should seed the AMD64 packages also.

Thanks again guys.

Note You need to log in before you can comment on or make changes to this bug.