Bug 114248 - Xft antialiasing looks badly if Gnome is not running
Xft antialiasing looks badly if Gnome is not running
Status: CLOSED DUPLICATE of bug 88259
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-25 08:38 EST by Alex Kanavin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
how the text in Mozilla looks before gnome-font-properties is run (6.51 KB, image/png)
2004-01-25 08:39 EST, Alex Kanavin
no flags Details
how the text looks after gnome-font-properties is run - see the difference (6.51 KB, image/png)
2004-01-25 08:45 EST, Alex Kanavin
no flags Details
oops, here's the correct 'text looks right' example (6.20 KB, image/png)
2004-01-25 08:50 EST, Alex Kanavin
no flags Details

  None (edit)
Description Alex Kanavin 2004-01-25 08:38:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When I am not running Gnome (instead, WindowMaker or twm) all
applications that use antialiasing look as if the red color is 
misconverged. Look at the screenshot below to see how it looks exactly.

The problem disappears if I either switch to Gnome (from WindowMaker) 
or run gnome-font-properties and then restart an application.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use switchdesk to switch to twm
2.Restart your session
3.Run mozilla
    

Additional info:
Comment 1 Alex Kanavin 2004-01-25 08:39:05 EST
Created attachment 97247 [details]
how the text in Mozilla looks before gnome-font-properties is run
Comment 2 Alex Kanavin 2004-01-25 08:45:20 EST
Created attachment 97248 [details]
how the text looks after gnome-font-properties is run - see the difference
Comment 3 Alex Kanavin 2004-01-25 08:50:13 EST
Created attachment 97249 [details]
oops, here's the correct 'text looks right' example
Comment 4 Owen Taylor 2004-01-25 08:54:57 EST

*** This bug has been marked as a duplicate of 88259 ***
Comment 5 Thomas Hartwig 2004-07-22 04:21:56 EDT
I can not see how bug 88259 is related to this one. I have exactly the
same behaviour like described by Alex Kanavin on a upgrade of RH9 to
FC2. The discussion on 88259 seems not to be related to this one. Just
to be sure I have tested the suggestions there, but nothing helps.

As said the font rendering is not working until you start eg:
gnome-font-properties

So please reopen this bug and apply this this for FC2 as well.
Comment 6 Alex Kanavin 2004-07-22 08:27:56 EDT
Oh, I can assure you it's certainly the same bug. Did you test the
suggestion in bug 88259 comment #37? Adding Xft.rgba: none to
Xresources fixed the problem very nicely for me.
Comment 7 Red Hat Bugzilla 2006-02-21 14:00:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.