Bug 114254 - six pack of compile time bugs
Summary: six pack of compile time bugs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-25 13:50 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 19:31:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-01-25 13:50:44 UTC
Description of problem:

I just tried to compile package gnome-media-2.4.0-2, from Redhat
Fedora Core 1.

The compiler said

1.

cddb-slave.c:824: warning: too few arguments for format

The source code is

                        g_print ("CDDB: Unknown response code: %d\n");

Clearly broken code sinec one %d specifier, and no integer supplied.

2.

cddb-slave.c:973: warning: format argument is not a pointer (arg 5)

The source code is

                g_warning ("Could not connect to %s:%s",
                           data->cddb->priv->server,
                           data->cddb->priv->port);

Suspect swap second %s for %d, because port is an integer.

3.

cddb-disclosure.c(119): remark #592: variable "indicator_size" is used
before its value is set

The source code is

                        *x = widget->allocation.x +
widget->allocation.width - (indicator_size + *x - widget->allocation.x);

But indicator_size doesn't get written to anywhere.

4.

prefs.c(60): warning #1011: missing return statement at end of
non-void function "reset_labels"

The source code is

        gtk_list_store_set (GTK_LIST_STORE (model), iter, 0, original,
-1);
}

5.

gsr-window.c(435): warning #1011: missing return statement at end of
non-void function "get_encoder_for_mimetype"

The source code is

        }
}

6.

gsr-window.c(1182): warning #117: non-void function "seek_to" should
return a value

The source code is

        if (old_state == GST_STATE_READY) {
                return;
        }

There is a return type for this function. A value should be returned.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Colin Walters 2004-05-19 19:31:31 UTC
All of these look to be fixed in gnome-media 2.6.0.


Note You need to log in before you can comment on or make changes to this bug.