Bug 114287 - missing return statement
missing return statement
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 05:40 EST by d.binderman
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 16:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-01-26 05:40:19 EST
Description of problem:

I just tried to compile package gnucash-1.8.7-1, from Redhat
Fedora Core 1.

The compiler said

1.

ofx_container_main.cpp(63): warning #1011: missing return statement at
end of non-void function
"OfxMainContainer::add_container(OfxGenericContainer *)"

The source code is

int OfxMainContainer::add_container(OfxGenericContainer * container)
{
  message_out(DEBUG,"OfxMainContainer::add_container for element " +
container->tag_identifier + "; destroying the generic container");
  /* Call gen_event anyway, it could be a status container or similar */
  container->gen_event();
  delete container;
}

Seems to be missing a return statement at the end of the routine.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-01-26 11:06:51 EST
What compiler are you using?
Comment 2 d.binderman 2004-01-26 17:07:53 EST
>What compiler are you using?

Intel 8.0 - it has three advantages over GNU

1. Numbered warning messages - see above.
2. More warning messages.
3. Better code generation.

Note You need to log in before you can comment on or make changes to this bug.