Bug 114298 - Sylpheed cores when opening inbox
Sylpheed cores when opening inbox
Status: CLOSED DUPLICATE of bug 114296
Product: Fedora
Classification: Fedora
Component: sylpheed (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 07:41 EST by Andrew D Kirch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D Kirch 2004-01-26 07:41:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
This appears to be a sylpheed bug on x86-64 machines.  It appears to
not handle opening a large inbox (however it is looking for "libJIS".
 As to how large (or if any size at all is large) I don't know. 
Strace output (in full) is available upon request, and a 'locate'
output for libJIS.so is included at the bottom of the strace.  I have
duplicated this bug with FreshRPM's sylpheed rpm (recompiled from
src.rpm) and the tarball on good-day.

Version-Release number of selected component (if applicable):
sylpheed-0.9.8a-1.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1. Run sylpheed
2. download a reasonable amount of e-mail (a couple hundred messages)
3. open inbox
    

Actual Results:  Sylpheed Segfaults

Expected Results:  Sylpheed should open the inbox displaying e-mail.

Additional info:

open("/usr/lib64/gconv/tls/x86_64/libJIS.so", O_RDONLY) = -1 ENOENT
(No such file or directory)
stat("/usr/lib64/gconv/tls/x86_64", 0x7fbfff8630) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/gconv/tls/libJIS.so", O_RDONLY) = -1 ENOENT (No such
file or directory)
stat("/usr/lib64/gconv/tls", 0x7fbfff8630) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/gconv/x86_64/libJIS.so", O_RDONLY) = -1 ENOENT (No
such file or directory)
stat("/usr/lib64/gconv/x86_64", 0x7fbfff8630) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/gconv/libJIS.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\n\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=99192, ...}) = 0
mmap(NULL, 1146024, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a98f94000
mprotect(0x2a98fac000, 1047720, PROT_NONE) = 0
mmap(0x2a99094000, 98304, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0) = 0x2a99094000
close(10)                               = 0
open("/usr/lib64/gconv/libGB.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\n\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=65856, ...}) = 0
mmap(NULL, 1112688, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a990ac000
mprotect(0x2a990bc000, 1047152, PROT_NONE) = 0
mmap(0x2a991ac000, 65536, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0) = 0x2a991ac000
close(10)                               = 0
open("/usr/lib64/gconv/libCNS.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0\16\0\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=465728, ...}) = 0
mmap(NULL, 1512560, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a991bc000
mprotect(0x2a9922e000, 1045616, PROT_NONE) = 0
mmap(0x2a992bc000, 466944, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 10, 0) = 0x2a992bc000
close(10)                               = 0
open("/usr/lib64/gconv/libKSC.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\t\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=45256, ...}) = 0
mmap(NULL, 1092088, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a9932e000
mprotect(0x2a99339000, 1047032, PROT_NONE) = 0
mmap(0x2a9942e000, 45056, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0) = 0x2a9942e000
close(10)                               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

[trelane@localhost trelane]$ locate libJIS.so
/usr/lib/gconv/libJIS.so
/usr/lib64/gconv/libJIS.so
Comment 1 Andrew D Kirch 2004-01-26 07:43:00 EST

*** This bug has been marked as a duplicate of 114296 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.