Bug 114300 - "Sanity check" produces a lot of warnings.
"Sanity check" produces a lot of warnings.
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 08:17 EST by Aleksey Nogin
Modified: 2013-06-23 22:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 12:12:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-01-26 08:17:01 EST
Not sure how harmful they are, but there sure are a lot of them!

See https://bugzilla.redhat.com/bugzilla/sanitycheck.cgi
Comment 1 David Lawrence 2004-01-26 16:59:59 EST
Most are because of the way the database was originally migrated from
Oracle to PostgreSQL. There are a couple PostgreSQL changes that need
to be done in sanity.cgi also. Neither of which I have had time to
address lately. I am going to revisit this all soon and clean up the
PostgreSQL port of Bugzilla to be more in line with the latest
Bugzilla CVS if someone else doesnt beat me to it.
Comment 2 Aleksey Nogin 2004-11-29 11:54:06 EST
This problem is still there...
Comment 3 David Lawrence 2004-11-29 12:17:16 EST
Yes. Work has not been done yet to clean out the database clutter. I will need
to make a script to use sanitycheck.cgi's output to go in and remove the clutter
at some point in the future. Hopefully with new application level checks and
other db checks further clutter should not occur over time.

Comment 4 Aleksey Nogin 2008-08-06 12:04:03 EDT
Is this still there with 3.2? I do not have permissions to run sanitycheck anymore, so can't check myself.
Comment 5 David Lawrence 2008-08-06 12:12:06 EDT
We have made even more effort with this migration to clear out as much of the clutter as possible and have narrowed down to just a few smaller sections. We will continue to fix up the remaining data issues now that they upgrade has past.
Sanitycheck.cgi is only accessible by admin users now and should not be accessible to the public.

Thanks for the report.
Dave

Note You need to log in before you can comment on or make changes to this bug.