Bug 114301 - Matlab crash due to XFree86?
Matlab crash due to XFree86?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 08:17 EST by Eva-Lena
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 08:32:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
matlab_crash_dump (8.16 KB, text/plain)
2004-01-26 08:21 EST, Eva-Lena
no flags Details

  None (edit)
Description Eva-Lena 2004-01-26 08:17:33 EST
Description of problem:
When I run SPM2 (Statistical Parametric Mapping, a graphical program
run in matlab) in Matlab 6.5.1 the letters of the graphical windows of
SPM2 are almost unreadable and matlab crashes after some procedures
(hard to give reproducable procedure). BUT, this does not happen if I
 ssh into this computer from another computer (with a different,
"older" os), then matlab and spm runs perfectly. I have tried with
matlab 6.0 but the same problem appears. This used to work fine until
I changed the os from Mandrake to Fedora. 
It seems to be some kind of "graphical" problem since matlab also
produces crash-dumps some times when I click on a window of the spm
program. Could it be an XFree86 bug?

Version-Release number of selected component (if applicable):
XFree86: 4.3.0-42
glibc: 2.3.2

How reproducible:
Always

Steps to Reproduce:
1.start matlab
2.spm
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Eva-Lena 2004-01-26 08:21:29 EST
Created attachment 97256 [details]
matlab_crash_dump
Comment 2 Mike A. Harris 2004-01-26 08:32:12 EST
The crash dump you've attached makes it rather clear IMHO that this
is a bug in Matlab itself.

If you have not already done so, please read the entire crash dump
that you've attached, and follow the detailed instructions given
inside the crash dump to report the problem to Matlab developers.

This Matlab bug is not an XFree86 bug/problem.

Closing 'NOTABUG'
Comment 3 Eva-Lena 2004-01-27 02:24:24 EST
I sent the matlab crash dump to the matlab developers a week ago. They
will perhaps have a bugfix in the next version of matlab. Is there any
way to downgrade Fedora so that I can still use Fedora and run Matlab
(since matlab has worked on other Linuxes)? I would really appreciate
your help! I am an inexperienced Linux user, what more than X is
running on the server if you are using a program on a client via ssh?

Thanks for your help!

/Eva-Lena
Comment 4 Barry K. Nathan 2004-09-03 20:27:32 EDT
Eva-Lena, what type of video card does your system have? (I can
reproduce this on some systems that I have access to, but not others,
and I'm starting to wonder if this is specific to certain video cards
or anything like that.)
Comment 5 Barry K. Nathan 2004-09-04 18:48:37 EDT
[I know this bug is closed as NOTABUG, but this is a good place to put
this information in case anyone else stumbles upon the same problem.]

Never mind my previous comment. The virtually-100% reproducible test
case my user found causes this crash on XFree86 4.1.0 and up, but not
XFree86 4.0.x and earlier. It doesn't seem to be the X server --
running a 3.3.6 server with the other packages at 4.1.0 also
reproduces the crash.

*However*, the remote end (where Matlab is actually running) also
seems to play a part. One remote computer I'm testing with, which has
a weird mix of RH 7.1, 7.2 and recompiled RHEL 2.1 packages, running a
recompiled RHEL 2.1 glibc and a mainline 2.4.26 kernel, does not
exhibit the crash. Two other remote computers, running Red Hat 9, do
have Matlab crashing; at least one of the two is running the exact
same Matlab binaries as the computer that's not crashing.

Note You need to log in before you can comment on or make changes to this bug.