Bug 114315 - /etc/httpd/conf.d/ssl.conf conflicts with virtual host
/etc/httpd/conf.d/ssl.conf conflicts with virtual host
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 10:35 EST by Michael
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.48-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 10:19:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2004-01-26 10:35:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Problem applies to RedHat 9 and Fedora Core 1. 

httpd ships with /etc/httpd/conf.d/ssl.conf in order to facilitate
https setup. 

However, this default configuration conflicts with use of
NameVirtualHost. 

To use NameVirtualHost one has to rename ssl.conf so that it does not
get loaded. 

There are probably other/better ways to do it, but I am not aware of
them. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 9/Fedora Core 1
2. Try to set up a NameVirtualHost - and fail
3. delete or rename /etc/httpd/conf.d/ssl.conf - NameVirtualHost works
    

Actual Results:  The default configuration should allow use of
NameVirtualHost. 



Additional info:

I don't know enough about apache config to make any specific
recommendations. But someone who knows about it should be able to make
some config changes so that the default config does not break
NameVirtualHost. 

If not, then there should be descriptive text in the
/etc/httpd/conf/httpd.conf file which warns about the conflict between
NameVirtualHost and ssl
Comment 1 Joe Orton 2004-01-26 11:02:48 EST
What NameVirtualHost directive did you use which conflicts with
ssl.conf?  One without ":80" at the end?
Comment 2 Michael 2004-01-26 12:48:18 EST
Correct ... I never specify :80 because on a couple of machines I
listen on other ports. 
Comment 3 Joe Orton 2004-01-27 09:27:47 EST
That is simply a config error.  I'll add this to the default
httpd.conf for the next release:

#
# NOTE: NameVirtualHost cannot be used without a port specifier 
# (e.g. :80) if mod_ssl is being used, due to the nature of the
# SSL protocol.
#

Note You need to log in before you can comment on or make changes to this bug.