Bug 11433 - pdflatex does not use the TEXINPUTS environment variable
Summary: pdflatex does not use the TEXINPUTS environment variable
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-16 07:57 UTC by dedu
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 13:39:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dedu 2000-05-16 07:57:06 UTC
TEXINPUTS environment variable is used when wanted to store image files
(for example) into one directory and find them in whatever directory
pdflatex is executed.  The tetex distribution with RedHat 6.2 does not take
this variable into accout when used with pdflatex.

Comment 1 Tim Waugh 2001-09-19 18:46:58 UTC
Do you know when, if ever, this last worked?  tetex-1.0.7-31 will have an 
updated pdftex (0.14h), so that might be worth a spin.


Comment 2 dedu 2001-09-20 07:10:03 UTC
I have just checked on RedHat 7.1 with tetex-1.0.7-15 and pdfTeX (Web2C 7.3.1)
3.14159-0.13d, and it does not work.  I cannot check on tetex-1.0.7-31 with
pdftex (0.14h) because it is not installed.


Comment 3 Tim Waugh 2001-09-26 13:07:51 UTC
If you can show me the exact test case that you are trying, I will be able to 
verify whether or not 1.0.7-31 really fixes this.  Thanks.


Comment 4 dedu 2001-09-26 13:39:01 UTC
eminescu:~/work$ echo $TEXINPUTS
:/usr/users/staginfo/dedu/doc/images
eminescu:~/work$ ls supelec.*
ls: supelec.*: No such file or directory
eminescu:~/work$ ls /usr/users/staginfo/dedu/doc/images/supelec.*
/usr/users/staginfo/dedu/doc/images/supelec.eps
/usr/users/staginfo/dedu/doc/images/supelec.pdf

Here is the file "test.tex"
---:
\documentclass[a4paper,twoside]{article}
\usepackage{graphicx}

\begin{document}
Hello world1.

\includegraphics{supelec.eps}
%\includegraphics{supelec.pdf}

Hello world2.
\end{document}
----

eminescu:~/work$ latex test.tex
[...] it's OK [TEXINPUTS taken into account]

After commenting out the eps line and removing % from the pdf line in file
test.tex:

eminescu:~/work$ pdflatex test.tex
This is pdfTeX, Version 3.14159-13d (Web2C 7.3.1)
(test.tex[/usr/share/texmf/pdftex/config/pdftex.cfg]
LaTeX2e <1998/12/01> patch level 1
Babel <v3.6x> and hyphenation patterns for american, french, german, ngerman, n
ohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 1999/01/07 v1.4a Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/graphics/graphicx.sty
(/usr/share/texmf/tex/latex/graphics/keyval.sty)
(/usr/share/texmf/tex/latex/graphics/graphics.sty
(/usr/share/texmf/tex/latex/graphics/trig.sty)
(/usr/share/texmf/tex/latex/config/graphics.cfg)
(/usr/share/texmf/tex/latex/graphics/pdftex.def))) (test.aux)
(/usr/share/texmf/tex/context/base/supp-pdf.tex
(/usr/share/texmf/tex/context/base/supp-mis.tex
loading : Context Support Macros / Missing
)
loading : Context Support Macros / PDF
)
Error: pdflatex (file supelec.pdf): cannot open image file

--------
Of course, if we put the file supelec.pdf in the current directory, all works
fine with pdflatex.

Eugen

Comment 5 Tim Waugh 2001-09-26 14:30:28 UTC
Okay, this works fine for me with pdftex 0.14h.  Since pdftex 0.14h is 
included in tetex-1.0.7-31 and later, I'm marking this closed.

Thanks for the test case.



Note You need to log in before you can comment on or make changes to this bug.