Bug 114340 - cms does not load on oracle
Summary: cms does not load on oracle
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 106481
TreeView+ depends on / blocked
 
Reported: 2004-01-26 21:27 UTC by Richard Li
Modified: 2007-04-18 17:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 22:28:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Li 2004-01-26 21:27:24 UTC
Description of problem:

CMS does not load on Oracle.

Version-Release number of selected component (if applicable):

nightly

How reproducible: always


Steps to Reproduce:
1. ccm load ccm-core
2. ccm load ccm-cms
  
Actual results:

Exception in thread "main" java.lang.IllegalStateException:
ccm-cms.pdl.mf:\ 58: no such resource
'com/arsdigita/content-types/ItemFileAttachment.pdl'
    at
com.arsdigita.persistence.pdl.ManifestSource.parse(ManifestSource.ja\va:94)
    at com.arsdigita.runtime.PDLInitializer.init(PDLInitializer.java:69)
    at
com.arsdigita.runtime.CompoundInitializer.init(CompoundInitializer.j\ava:97)
    at
com.arsdigita.runtime.CompoundInitializer.init(CompoundInitializer.j\ava:97)
    at com.arsdigita.runtime.Startup.run(Startup.java:215)
    at com.arsdigita.packaging.Loader.loadData(Loader.java:109)
    at com.arsdigita.packaging.Load.run(Load.java:341)
    at com.arsdigita.packaging.MasterTool.main(MasterTool.java:90)



Expected results:

System loads.

Additional info:

Comment 1 Richard Li 2004-01-26 22:01:09 UTC
This happens on PostgreSQL too.

-> high severity, since this blocks development

Comment 2 Richard Li 2004-01-26 22:28:35 UTC
I think I had some old PDL lying around in some JARs...works on both.


Note You need to log in before you can comment on or make changes to this bug.