Bug 114354 - java seg faults after a recent glibc update is applied.
java seg faults after a recent glibc update is applied.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Karen Bennet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 21:40 EST by Ronald Cole
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL3ES2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 17:47:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2004-01-26 21:40:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
On RHEL3.0ES with *everything* installed and fully updated via
up2date, the IBM JVM seg faults right away.

Version-Release number of selected component (if applicable):
IBMJava2-JRE-1.4.1-8

How reproducible:
Always

Steps to Reproduce:
1. java -version

    

Actual Results:  
Segmentation fault

Expected Results:  
java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM build cxia32141-20030522 (JIT
enabled: jitc))


Additional info:

The IBM JVM seemed to work ok on the Beta release and after the
initial iso install.  However, it seemed to start segfaulting after
the glibc update (reinstalling to be sure is not an option for me).
Comment 1 Ronald Cole 2004-01-30 14:02:20 EST
Apparently it currently works with LD_ASSUME_KERNEL=2.2.5, although it
was working without it on Taroon Beta at least...
Comment 2 Ronald Cole 2004-03-31 19:30:54 EST
The latest Java2 SDK from IBM (IBMJava2-SDK-1.4.1-2.0.i386.rpm)
appears to be working without needing to set LD_ASSUME_KERNEL.  How
about generating an errata release sometime soon?  Pretty please?

$ java -version
java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM build cxia321411-20040301 (JIT
enabled: jitc))
Comment 3 Jeremy Handcock 2004-04-20 17:34:05 EDT
I have an up2date RHEL3 box with IBMJava2-JRE-1.4.1-8 on it, and I
can't reproduce this.  Running `java -version' gives:

java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM build cxia321411-20030917 (JIT
enabled: jitc))

This is a different build than the one that is segfaulting on you. 
Are you sure you have 1.4.1-8?
Comment 4 Ronald Cole 2004-04-20 18:07:34 EDT
Yes.

$ rpm -qa IBMJava2
IBMJava2-JRE-1.4.1-8
IBMJava2-SDK-1.4.1-9
$ type java
java is /opt/IBMJava2-141/bin/java
$ java -version
java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM build cxia321411-20030917 
(JIT enabled: jitc))

It appears to be working now, 11-weeks and many updates after I 
reported the bug.  I guess there is merit in the "ignore it and maybe 
it will eventually resolve itself" approach to bug fixing!  ;)
Comment 5 Ronald Cole 2004-04-29 18:04:47 EDT
Well, IBMJava2-JRE-1.4.1-8 may be working for a "-version", but it
won't run eclipse!

Try it with "eclipse -vm /opt/IBMJava2-141/bin/java" and watch how
fast it tosses up an error window!

I was able to successfully start eclipse if I used the IBM supplied
RPM listed above in comment #2 (without needing LD_ASSUME_KERNEL at all)!!

So, I'll ask again for Red Hat to make an errata release to the newer
1.4.1 JVM from IBM.

Note You need to log in before you can comment on or make changes to this bug.