Bug 114362 - GDK_USE_XFT=0 does not work anymore
Summary: GDK_USE_XFT=0 does not work anymore
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtk2
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-27 10:39 UTC by Enrico Scholz
Modified: 2007-04-18 17:02 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-01-27 15:13:28 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2004-01-27 10:39:44 UTC
Description of problem:

$GDK_USE_XFT seems to be ignored in recent gtk2 snapshot so that every
gtk-based application uses AA fonts now. This makes nearly all text
based applications unusable on TFT monitors; tweaking with
gnome-fonr-properties does not help.

Some applications can be cured by assigning a bitmap font as system
font, but important applications like browsers are using the fonts
suggested by the page. Therefore, this does not help really.

KDE/QT knows such a setting (qtconfig - >Fonts -> Enable
Anti-Aliased...) and gtk-2.2. supports it too, so it seems to be
doable to add this functionality.


Version-Release number of selected component (if applicable):

gtk2-2.3.2-2

Comment 1 Owen Taylor 2004-01-27 15:13:28 UTC
Not a bug, the code has been removed for GTK+-2.3.x. (And hadn't
been maintained for several years, never worked well. It's
an *entirely* different code path.)

I'm not sure what's different about TFT monitors. Many
of us use antialiased fonts on laptops, etc, and like it.
(Since you mention GNOME, I don't think it's bug 88259)

If you want precanned bitmap fonts, just put them in ~/.fonts or
/usr/share/fonts (see the release notes for details).



Note You need to log in before you can comment on or make changes to this bug.