Bug 114372 - 5 * used before set
5 * used before set
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: Gtk-Perl (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
: 121263 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 07:29 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-22 19:18:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-01-27 07:29:10 EST
Description of problem:

I just tried to compile package Gtk-Perl-0.7008-35 from Redhat
Fedora Core 1.

The compiler said

1.

GtkObject.xs(860): remark #592: variable "signals" is used before its
value is set

The source code is

	sv_setiv(s, signals);

Suggest initialise variable signals before first use.

2.

GdkImlib.xs(445): remark #592: variable "RETVAL" is used before its
value is set

Source code is

	sv_setpvn(RETVAL, mod, 256);

3.

GdkImlib.xs(457): remark #592: variable "RETVAL" is used before its
value is set

Source code is

	sv_setpvn(RETVAL, mod, 256);

4.

GdkImlib.xs(469): remark #592: variable "RETVAL" is used before its
value is set

	sv_setpvn(RETVAL, mod, 256);

5.

GnomeDockLayout.xs(57): remark #592: variable "RETVAL" is used before
its value is set

	sv_setpv(RETVAL, ret);


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Warren Togami 2005-09-07 06:08:36 EDT
*** Bug 121263 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.