Bug 114386 - /usr/bin/crontab enters an endless loop on syntax error in crontab
/usr/bin/crontab enters an endless loop on syntax error in crontab
Status: CLOSED DUPLICATE of bug 89937
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 10:40 EST by Andrey Petrov
Modified: 2007-04-18 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Flag "numbers" with 0 characters as errors (272 bytes, patch)
2004-01-30 10:32 EST, Miloslav Trmac
no flags Details | Diff

  None (edit)
Description Andrey Petrov 2004-01-27 10:40:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040117

Description of problem:
if you try to install the following job with crontab -e
$ crontab -e
(EDITOR pops up)
*/ * * * * command
(save file, quit editor)
Instead of returning to the prompt the /usr/bin/crontab program enters
an endless loop, consuming 100% of the cpu cycles.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. crontab -e
2. */ * * * * any-command
3. save file, quit editor
    

Actual Results:  /usr/bin/crontab entered an endless loop

Expected Results:  An error message explaining that there was a syntax
error in the crontab

Additional info:
Comment 1 Miloslav Trmac 2004-01-30 10:32:04 EST
Created attachment 97368 [details]
Flag "numbers" with 0 characters as errors

The attached patch should fix this border case.
Comment 2 Jens Petersen 2004-06-30 12:39:58 EDT

*** This bug has been marked as a duplicate of 89937 ***
Comment 3 Jens Petersen 2004-06-30 12:40:19 EDT
Thanks for the patch.
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.