This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 114397 - Anaconda backtraces after loading 2nd stage.
Anaconda backtraces after loading 2nd stage.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 12:18 EST by Tom Diehl
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-24 08:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Diehl 2004-01-27 12:18:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When doing a pxe/nfs fresh install anaconda backtraces just after
loading the 2nd stage.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.pxe boot machine
2.answer the questions
3.Once the 2nd stage loads I get a backtrace.
    

Actual Results:  backtrace occurred:


Expected Results:  Normal install

Additional info:

File /usr/bin/anaconda line 574 in
isys.mount ("/selinux", "/selinux", "fstype=selinuxfs"
file /usr/lib/anaconda/isys.py line 172 in mount
rc = _isys.mount(fsdevice, type, location, readonly, bindMount, remount)
SystemError: (19, 'no such device')
install exited abnormally.

I had to copy this by hand so if something looks weird about the above
let me know and I will provide more info.
Comment 1 Tom Diehl 2004-01-27 12:19:41 EST
Oh and one more thing, I am using selinux=0 at boot time to get around
the dhcp bug.
Comment 2 Jeremy Katz 2004-01-27 13:02:13 EST
Booting with 'selinux=0', although a workaround for the DHCP thing is
going to cause lots of other problems during installation.

I'd rather get a fix for bug 114092 and not have to boot with
'selinux=0' :-)
Comment 3 Tom Diehl 2004-01-27 14:10:05 EST
OK. I reran anaconda without selinux=0 and I set the address manually.
This appears to fix that problem. I now can get up to the point where
it fails with some kind of pango error. Are you aware of this error or
should I file a bug with the information? The first line of the error is 
GetTextSearchFlags is not an eunm type. If you want a bug what
component should I file it against?? Anaconda??

Should we just close this??

Thanks.
Comment 4 Jeremy Katz 2004-01-27 15:43:36 EST
The pango error is already known.  Going to leave this open as the
failure mode for selinux=0 should be nicer :)
Comment 5 Tom Diehl 2004-01-30 09:35:11 EST
FWIW, I ran anaconda this morning with the image from Jan 29 and
setting selinux=0 appears to now do the right thing (tm). I did not
actually complete the install but I ran it up to the point of
selecting packages and everything seemed fine.
Comment 6 Jeremy Katz 2004-01-30 11:13:12 EST
Yeah, I fixed this now :)
Comment 7 Jeremy Katz 2004-04-15 00:51:14 EDT
This should be good with current trees

Note You need to log in before you can comment on or make changes to this bug.