Bug 114404 - Rebuild of src rpm fails with syntax errors
Rebuild of src rpm fails with syntax errors
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 14:30 EST by Brian Bruns
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 10:59:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Bruns 2004-01-27 14:30:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win32; en-US; rv:1.5)
Gecko/20031016 K-Meleon/0.8.2

Description of problem:
Rebuilding the util-linux src rpm fails with various errors in blockdev.c

Version-Release number of selected component (if applicable):
util-linux-2.11y-35.sel.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Get util-linux-2.11y-35.sel.src.rpm
2. rpmbuild --rebuild util-linux-2.11y-35.sel.src.rpm

    

Actual Results:  cc -O2 -g -march=i386 -mcpu=i686 -D_LARGEFILE_SOURCE
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -I../lib -Wall
-Wmissing-prototypes -Wstrict-prototypes -I/usr/include/ncurses
-DNCH=0 -I/usr/include/slang  -D_FILE_OFFSET_BITS=64
-DSBINDIR=\"/sbin\" -DUSRSBINDIR=\"/usr/sbin\" -DLOGDIR=\"/var/log\"
-DVARPATH=\"/var\" -DLOCALEDIR=\"/usr/share/locale\" -O2 -g
-march=i386 -mcpu=i686    blockdev.c   -o blockdev
blockdev.c:70: error: syntax error before '[' token
blockdev.c:70: error: initializer element is not constant
blockdev.c:70: error: (near initialization for `bdcms[4].ioc')
blockdev.c:70: error: initializer element is not constant
blockdev.c:70: error: (near initialization for `bdcms[4]')
blockdev.c:73: error: syntax error before '[' token
blockdev.c:73: error: initializer element is not constant
blockdev.c:73: error: (near initialization for `bdcms[5].ioc')
blockdev.c:73: error: initializer element is not constant
blockdev.c:73: error: (near initialization for `bdcms[5]')
blockdev.c:76: error: initializer element is not constant
blockdev.c:76: error: (near initialization for `bdcms[6]')
blockdev.c:79: error: initializer element is not constant
blockdev.c:79: error: (near initialization for `bdcms[7]')
blockdev.c:82: error: initializer element is not constant
blockdev.c:82: error: (near initialization for `bdcms[8]')
blockdev.c:85: error: initializer element is not constant
blockdev.c:85: error: (near initialization for `bdcms[9]')
blockdev.c:89: error: initializer element is not constant
blockdev.c:89: error: (near initialization for `bdcms[10]')
blockdev.c: In function `report_device':
blockdev.c:333: error: syntax error before '[' token
make[1]: *** [blockdev] Error 1
make[1]: Leaving directory
`/usr/src/redhat/BUILD/util-linux-2.11y/disk-utils'
make: *** [all] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.30713 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.30713 (%build)

Expected Results:  Should have successfully rebuilt the rpm from the
source

Additional info:
Comment 1 Elliot Lee 2004-02-24 10:59:32 EST
Can't reproduce with util-linux-2.12-3

Note You need to log in before you can comment on or make changes to this bug.