Bug 11441 - termcap changes for xterm break display on other operating systems (Solaris)
termcap changes for xterm break display on other operating systems (Solaris)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: termcap (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-16 07:32 EDT by Henning P. Schmiedehausen
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 07:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning P. Schmiedehausen 2000-05-16 07:32:34 EDT
Hi,

I'm in the "unfortunate" situation to work in a shop where we have
everything from Solaris 2.5.1 to 2.7 and RH Linux 4.2 to 6.2 in active use.
I'm a strong advocate for RHL here (though we have SuSE head offices just
about 150 metres from here) so we're going with it since about 1996.

On all our systems with a graphical desktop, especially the solaris boxes,
opening a rlogin or slogin connection from a local running XTerm to a
RH 6.2 box completely screws up the reverse and normal video display.
black on white text is partially white on black, rows of spaces are
reverse videoed and programs like emacs which use ncurses are almost
impossible to use.

If you enter "export TERM=xterm-r6" then everything is fine again. We now
had this annoying mis-feature with two or three system upgrades and I
really start to get fed up with such unnecessary changes which screw up
running day-to-day operations.

Please revert to "xterm-r6" as the default xterm and make xterm-redhat or
xterm-xfree86 optional choices. There _is_ a world outside Windows, oops
RedHat Linux.
Comment 1 Bernhard Rosenkraenzer 2000-08-30 10:01:21 EDT
The changes are intentional and standards compliant (Debian, SuSE, Mandrake and
probably FreeBSD are using the same termcap definition for xterm).
LSB requires the use of these definitions.
Comment 2 Henning P. Schmiedehausen 2000-08-31 04:24:37 EDT
You're doing the same mistakes as windows and you will be doomed to have the
same fate as Windows.
You're doing the same mistakes as windows and you will be doomed to have the
same fate as Windows.
Comment 3 Simon Hill 2000-10-30 18:56:15 EST
I do not consider this issue RESOLVED. xterms do not work properly on AIX
either. I say the LSB is offbase here - the xterm does not belong exclusively to
Linux, and xterms should interoperate with other forms of Unix without having to
change the TERM variable.

Note You need to log in before you can comment on or make changes to this bug.