Bug 114414 - cups daemon crashes after sharing local printer
cups daemon crashes after sharing local printer
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 16:10 EST by Michel Lacle
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 00:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cupsd.conf cups configuration file (19.98 KB, text/plain)
2004-01-27 16:13 EST, Michel Lacle
no flags Details
cupsd.conf after printer was shared out to remote host (19.93 KB, text/plain)
2004-01-28 15:34 EST, Michel Lacle
no flags Details
cupsd.conf (19.92 KB, text/plain)
2004-02-03 13:47 EST, Michel Lacle
no flags Details

  None (edit)
Description Michel Lacle 2004-01-27 16:10:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
When using the redhat-config-print tool to share a local printer, the
cups deamon dies on restart. I have updated the redhat-config-print tool
after looking at similar cases on bugzilla. Here are the versions.

redhat-config-printer-gui-0.6.47.9-1
redhat-config-printer-0.6.47.9-1

This is the message in the cups error log file:

E [27/Jan/2004:16:01:20 -0500] StartListening: Unable to bind socket -
Cannot assign requested address.


Version-Release number of selected component (if applicable):
cups-1.1.17-13.3

How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-printer
2. Select a queue, select Sharing from the Action menu
3. Check: This queue is available to others
4. Add: Type IP in "Single IP Address" Hit OK twice
5. Hit Apply
6. ps -eaf | grep cups and cups is not there
    

Actual Results:  [root@seabreeze cups]# tail -f /var/log/cups/error_log
I [27/Jan/2004:16:15:26 -0500] LoadPPDs: No new or changed PPDs...
E [27/Jan/2004:16:15:26 -0500] StartListening: Unable to bind socket -
Cannot assign requested address.
I [27/Jan/2004:16:15:26 -0500] Sending browsing info to a376ffff:631
I [27/Jan/2004:16:15:26 -0500] Listening to 7f000001:631
I [27/Jan/2004:16:15:26 -0500] Listening to a3760f6d:631
I [27/Jan/2004:16:15:26 -0500] Configured for up to 100 clients.
I [27/Jan/2004:16:15:26 -0500] Allowing up to 10 client connections
per host.
I [27/Jan/2004:16:15:26 -0500] LoadPPDs: Read "/etc/cups/ppds.dat", 13
PPDs...
I [27/Jan/2004:16:15:26 -0500] LoadPPDs: No new or changed PPDs...
E [27/Jan/2004:16:15:27 -0500] StartListening: Unable to bind socket -
Cannot assign requested address.


Expected Results:  cups should have started without errors.

Additional info:
Comment 1 Michel Lacle 2004-01-27 16:13:03 EST
Created attachment 97284 [details]
cupsd.conf cups configuration file

This is the cups configuration file after the bug was produced.
Comment 2 Tim Waugh 2004-01-28 11:54:54 EST
Please this these experimental packages and letm e know if they fix it
for you:

http://cyberelk.net/tim/data/tmp/redhat-config-printer-0.6.47.12-1.i386.rpm
http://cyberelk.net/tim/data/tmp/redhat-config-printer-gui-0.6.47.12-1.i386.rpm
Comment 3 Michel Lacle 2004-01-28 13:12:49 EST
I'm getting the following conflicts, should I do a --force ?

[root@seabreeze root]# rpm -ivh redhat-config-printer-0.6.47.12-1.i386.rpm
Preparing...               
########################################### [100%]
        file /usr/bin/magicfilter-t from install of
redhat-config-printer-0.6.47 .12-1 conflicts with file from package
redhat-config-printer-0.6.47.11-1
        file /usr/share/man/man5/magicfilter.5.gz from install of
redhat-config- printer-0.6.47.12-1 conflicts with file from package
redhat-config-printer-0.6.4 7.11-1
        file /usr/share/man/man8/magicfilter.8.gz from install of
redhat-config- printer-0.6.47.12-1 conflicts with file from package
redhat-config-printer-0.6.4 7.11-1
        file /usr/share/printconf/util/backend.py from install of
redhat-config- printer-0.6.47.12-1 conflicts with file from package
redhat-config-printer-0.6.4 7.11-1
        file /usr/share/printconf/util/printconf_conf.py from install
of redhat- config-printer-0.6.47.12-1 conflicts with file from package
redhat-config-printe r-0.6.47.11-1
        file /usr/share/printconf/util/printconf_tui.py from install
of redhat-c onfig-printer-0.6.47.12-1 conflicts with file from package
redhat-config-printer -0.6.47.11-1
        file /usr/share/printconf/util/printconf_version.py from
install of redh at-config-printer-0.6.47.12-1 conflicts with file from
package redhat-config-pri nter-0.6.47.11-1
Comment 4 Tim Waugh 2004-01-28 13:31:24 EST
Use 'rpm -Fvh ...' not 'rpm -ivh ...'.
Comment 5 Michel Lacle 2004-01-28 15:34:11 EST
Created attachment 97308 [details]
cupsd.conf after printer was shared out to remote host
Comment 6 Michel Lacle 2004-01-28 15:37:15 EST
The cups deamon does not die anymore, however now I'm not able to
print from the remote host.

Trying to telnet into port 631 doesn't work either(connection refused). 

Printing locally(the machine that is sharing the printer) does
work(has always worked).
Comment 7 Tim Waugh 2004-01-28 18:28:01 EST
I expect you'll find that it works for other sharing modes, but yes it
ought to work in this case too.
Comment 8 Tim Waugh 2004-01-30 05:06:58 EST
Can you show me the output of '/sbin/ifconfig' please?
Comment 9 Michel Lacle 2004-01-30 11:19:45 EST
[root@seabreeze root]# /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0B:DB:3D:BE:4F
          inet addr:163.118.12.190  Bcast:163.118.12.255 
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9351102 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7259342 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:961986324 (917.4 Mb)  TX bytes:3484976653 (3323.5 Mb)
          Interrupt:9 Base address:0xdcc0 Memory:ff6e0000-ff700000
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3291000 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3291000 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:258883180 (246.8 Mb)  TX bytes:258883180 (246.8 Mb)
 
[root@seabreeze root]#
Comment 11 Michel Lacle 2004-02-03 13:46:57 EST
I tried the last packages, and I am now able to print from the remote
host I have specified in the "Sharing" Options.

However I am also able to print from any other host that were not
specified.

I attached cupsd.conf
Comment 12 Michel Lacle 2004-02-03 13:47:25 EST
Created attachment 97445 [details]
cupsd.conf
Comment 13 Tim Waugh 2004-02-03 15:26:44 EST
You can *print* from machines other than 163.118.15.109?  Or just see
the print queues names in the browse list?  What sort of machine is
163.118.15.109?
Comment 14 Michel Lacle 2004-02-05 13:57:25 EST
Looks like it's working now.

163.118.15.109 is a RedHat 9 machine. This machines is the only
machine allowed to print on the printer shared out by 163.118.12.109.

Printing from .15.109 works(only one allowed).
Printing from localhost(.12.109) works.

Printing from .128.211 is denied(which is how it is supposed to work).

Looks like it's working the way I want to.
Comment 15 michel Godin 2004-02-06 11:55:18 EST
I've succeeded in printer sharing (why me?) on a updated RH9. I've
found 3 problems:

*Listen statements: If multiple Listen ip-like statements can be
envisionned, they should (may-be) all refer to the same
printer-server. For me, the only permitted Listen are 127.0.0.1
(local-printing?) and My-print-server-ip (necessary). Otherwise the
cups daemon stops, and cannot be restarted until you remove any other
Listen line.

*Allow statements: here must be the ip of the clients. But no kind of
mask works, neither aa.bb.cc.dd/nn nor aa.bb.cc.dd/mm.mm.mm.mm. The
only kind-of-a-mask is the star char: aa.bb.cc.* works. Didn't try
aa.bb.cc(period). Of course, printconf-gui doesn't accept star chars...

I've also noticed that the printer-deletion is ugly: the deleted
printer never disapears, but becomes an orphan (!!!)

*Firewall config: unless your hidden from the internet (i'm not), you
choose firewalling. Whereas in RH7.x port 515 was tolerated with
Medium firewalling, now you've got to specify port 631 in firewall
config (aka 631:tcp, not 631:udp - unsufficient). I've even tried
Fedora, but with on/off firewall-config, i should have writen my own
iptables: Too unsecure.
I think tcp 631 and  (ARP) should (always?) be enabled in Fedora and RH9.
Comment 16 Tim Waugh 2004-02-06 11:58:52 EST
Michel: your comment is no good to me at all without the *version
number* of the redhat-config-printer package.

Plus: do *NOT* pile several bugs into one bug report, but file a
separate bug report for each issue.  Otherwise bugs get lost.
Comment 17 michel Godin 2004-02-07 07:09:16 EST
redhat-config-printer-0.6.47.11-1
redhat-config-printer-gui-0.6.47.11-1
when i wrote firewalling, please read redhat-config-securitylevel as
created by anaconda.
Comment 18 michel Godin 2004-02-07 08:36:01 EST
do *NOT* pile several bugs into one bug report
it's a point of view. my problem is solved, and i think of those (i've
been one) who see no printer sharing at all because of bad firewall
config. 
Comment 19 Michel Lacle 2004-02-07 13:23:30 EST
There are two Michel's in here Tim, don't get confused :-).

Comment #14 describes my last correspondence, if you need me to test
any more scenarios for you let me know.
Comment 20 John Flanagan 2004-05-12 00:42:14 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-071.html

Note You need to log in before you can comment on or make changes to this bug.