Bug 114417 - Installing dies with strange dependence
Summary: Installing dies with strange dependence
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: spamassassin   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-27 21:32 UTC by Robert Scheck
Modified: 2007-04-18 17:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 19:07:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-01-27 21:32:43 UTC
Description of problem:
Mail-SpamAssassin source RPM was correct rebuilded from Fedora 
Development:

--- snipp ---
tux # rpm -Uvh spamassassin-2.63-5.i386.rpm
Error: Failed dependencies:
        /usr/lib/perl5/vendor_perl/5.8.0 is needed by spamassassin-2.63-5
tux # 
tux # file /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl/5.8.0: directory
tux # 
--- snapp ---

Uhm?

Version-Release number of selected component (if applicable):
spamassassin-2.63-5

How reproducible & Steps to Reproduce:
1. Get the latest source RPM
2. rpmbuild -bb [source RPM]
3. rpm -Uvh [new binary RPM]
4. Get the error :-(
  
Actual results:
The problem is caused by the change of the following in the spec
file:

25c25
< Requires: %(perl -le 'use Config; print $Config{archlibexp}')
---
> Requires: %(perl -le 'use Config; print $Config{vendorlibexp}')

Expected results:
Fix the problem, please... :-)

Comment 1 Robert Scheck 2004-02-13 19:07:06 UTC
It's fixed using

Requires: %(perl -le 'use Config; print $Config{sitelibexp}')

Thank you :)


Note You need to log in before you can comment on or make changes to this bug.