Bug 1144440 - Upgrade to latest upstream systemd scripts
Summary: Upgrade to latest upstream systemd scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: JianHong Yin
URL:
Whiteboard:
: 1089417 1109962 1120852 (view as bug list)
Depends On:
Blocks: 1090668
TreeView+ depends on / blocked
 
Reported: 2014-09-19 11:54 UTC by Steve Dickson
Modified: 2019-04-16 14:18 UTC (History)
14 users (show)

Fixed In Version: nfs-utils-1.3.0-0.3.el7
Doc Type: Enhancement
Doc Text:
Feature: Use the upstream systemd scripts. Reason: They work better and are more efficient than the original ones. Result: RHEL7.1 now used the systemd script that are in upstream.
Clone Of:
Environment:
Last Closed: 2015-03-05 13:11:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0508 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2015-03-05 16:14:48 UTC

Description Steve Dickson 2014-09-19 11:54:35 UTC
Description of problem:
To correctly fix some existing bugs, the current systemd
scripts need to be upgrade to the upstream systemd script. 

Also, the upstream scripts are much better on how and when to
start the numerous nfs-utils daemons.

Additional info:
The needed Fedora commits:

commit 1af376fa7983e2cdbef50adf227a6621a051293e
Author: Steve Dickson <steved@redhat.com>
Date:   Sat May 24 11:29:46 2014 -0400

    Use systemd_post macro to enable services (bz 1087950)
    
 

commit 2abd2dd759e959f9ec6b238398826e62f09426dc
Author: Steve Dickson <steved@redhat.com>
Date:   Thu May 1 10:49:42 2014 -0400

    start-statd: rpc.statd's systemd unit changed names

commit 47aa7d9e2d69f640010b08ef281b761e9dae2e7c
Author: Steve Dickson <steved@redhat.com>
Date:   Tue Mar 25 12:36:54 2014 -0400

    Incorporated new upstream systemd units

Comment 8 Steve Dickson 2014-10-14 13:40:16 UTC
*** Bug 1109962 has been marked as a duplicate of this bug. ***

Comment 9 Steve Dickson 2014-10-21 17:17:48 UTC
*** Bug 1089417 has been marked as a duplicate of this bug. ***

Comment 10 Steve Dickson 2014-10-21 17:24:34 UTC
*** Bug 1120852 has been marked as a duplicate of this bug. ***

Comment 13 Aneta Šteflová Petrová 2015-01-30 08:11:24 UTC
Steve, could you please provide a description for this bug? You can follow the preset template in the Doc Text field.

Comment 15 errata-xmlrpc 2015-03-05 13:11:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0508.html


Note You need to log in before you can comment on or make changes to this bug.