Bug 114450 - Hook for log files
Hook for log files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rh-postgresql (Show other bugs)
3.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom Lane
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 06:44 EST by Mario Lorenz
Modified: 2013-07-02 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 15:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Lorenz 2004-01-28 06:44:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030708

Description of problem:
Postgres has features to log debug output, queries etc. to
stdout/stderr. The rhdb start script redirects this to /dev/null.

It should be possible to configure this to log into a file,
or even better into a program, so that this output is lost. 

Currently this cannot be done safely, because /etc/rc.d/init.d/rhdb
is not marked to be a configuration file, so changes would be lost
on an update.


Version-Release number of selected component (if applicable):
rh-postgresql-server 7.3.4-9

How reproducible:
Always

Steps to Reproduce:
1. look into the rhdb service start file where postmaster is started
2. notice the >/dev/null 2&>1
3.
    

Actual Results:  output logged to the bit bucket

Expected Results:  A possibility, either by setting a variable in
sysconfig/rhdb ,
to log to a file or a program, alternatively setting the start script
to be a config file so that changes can be made safely.


Additional info:

Inhouse, we pipe the log to /usr/sbin/rotatelogs from the httpd package
and use tmpwatch to clean out older logfiles. This would however be
a bad default configuration because it adds dependencies to httpd.
A  sysconfig configuration variable, which can default to
>/dev/null would have zero impact on current system, but  make
advanced logging possible.
Comment 1 Suzanne Hillman 2004-02-02 13:46:49 EST
Internal RFE bug #114775 added. Will be considered for future releases.
Comment 2 Suzanne Hillman 2004-04-21 15:02:41 EDT
Postgres server not supported in RHEL3.

Note You need to log in before you can comment on or make changes to this bug.