Bug 11446 - Appletalk not loading
Appletalk not loading
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-16 11:16 EDT by Bryan Schappel
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 17:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Schappel 2000-05-16 11:16:42 EDT
After installing version 6.2 and netatalk+asun (latest version on the
contrib site) the Appletalk protocols no longer load. When running
atalkd from the command line or at startup the following errors are
generated:

socket: invalid argument
socket: invalid argument
atalkd: can't get interfaces, exiting

The solution is to downgrade to 6.1.

Is this a kernel problem?

I have tried the latest kernel with the same results.
Comment 1 Alexandre Parenteau 2000-07-31 12:57:26 EDT
Doing a "insmod appletalk" before starting netatalk is a work-around to 

this problem.
Comment 2 Bill Nottingham 2002-04-01 22:12:48 EST
Changing the alias for net-pf-5 to 'appletalk' instead of 'none' should fix this.

Note You need to log in before you can comment on or make changes to this bug.