Bug 114491 - Intermedia searching broken for phrases
Intermedia searching broken for phrases
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Li
Jon Orris
:
Depends On:
Blocks: 106481
  Show dependency treegraph
 
Reported: 2004-01-28 12:45 EST by Jon Orris
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 14:19:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2004-01-28 12:45:24 EST
Description of problem:
@39825/oracle-se

Intermedia searching broken for phrases. If I search for 'foo bar
baz', the search will fail. Searching 'foo' or 'bar' or 'baz' works fine.

Looking at the logs, the problem is that the query is improperly
formatted. It is (simplified):
select object_id from search_content c  where (contains(c.xml_content,
'"Foo"and"Bar"and"Baz"', 1) > 0);

no rows selected
                                                                     
                                                       

Instead of:
select object_id from search_content c  where (contains(c.xml_content,
'"Foo" and "Bar" and "Baz"', 1) > 0);

 OBJECT_ID
----------
       706
Comment 1 Richard Li 2004-01-28 13:36:58 EST
Fixed @39839
Comment 2 Jon Orris 2004-01-28 14:19:41 EST
verified

Note You need to log in before you can comment on or make changes to this bug.