Bug 114496 - fatal initscripts package error during install.
Summary: fatal initscripts package error during install.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-28 18:52 UTC by Mike McLean
Modified: 2015-01-04 22:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 14:01:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of rpm on VC2 (5.96 KB, text/plain)
2004-01-28 20:17 UTC, Mike McLean
no flags Details
log of /proc/mounts and install.log during install (135.71 KB, text/plain)
2004-01-28 21:23 UTC, Mike McLean
no flags Details

Description Mike McLean 2004-01-28 18:52:03 UTC
* FC2-re0127.3
* initscripts-7.43-2

anaconda reports an fatal error installing initscripts.  Happening on
all installs.

VC1 shows a bunch of errors from rpmdb like
rpmdb: /var/lib/rpm/Triggername: unable to flush: Read-only file system
(repeat for various rpm related files)

Comment 1 Bill Nottingham 2004-01-28 19:23:08 UTC
What is the error?

Comment 2 Mike McLean 2004-01-28 20:17:21 UTC
Created attachment 97307 [details]
output of rpm on VC2

this is the output of running
% rpm --root /mnt/sysimage -ivh /mnt/source/Fedora/RPMS/initscripts-.....

There are a bunch of errors about being unable to create files.  Somehow
/mnt/sysimage managed to get remounted as read-only.

So, probably not an initscripts bug (unless initscripts did the remount).  Not
really sure where problem is coming from....

Comment 3 Bill Nottingham 2004-01-28 20:29:45 UTC
The first warning is just a key thing. The %pre failed presumably
because of the read-only filesystem.

Punting to anaconda.

Comment 4 Jeremy Katz 2004-01-28 21:11:51 UTC
This was the first kernel bug that we hit last night.  sct has a fix
for it, but then we hit more :/

Comment 5 Mike McLean 2004-01-28 21:23:30 UTC
Created attachment 97311 [details]
log of /proc/mounts and install.log during install

This log shows the output of:
  - date
  - grep /mnt/sysimage /proc/mounts
  - tail -n 3 /mnt/sysimage/root/install.log
during the course of the install.

As you can see, /mnt/sysimage is mounted read-write until anaconda begins
installing initscripts.  At that point:
  - /mnt/sysimage shows up as being mounted read-only
  - the tail of install.log contains only null characters

Comment 6 Mike McLean 2004-02-04 20:36:23 UTC
I am no longer seeing these symptoms in the installer.  Is this bug
fixed in the kernel, or has Jeremy implemented a workaround in the
installer?  If the former, please close.

Comment 7 Jeremy Katz 2004-02-04 20:43:00 UTC
Just worked around for now (we're not doing selinux stuff for test1 :()

Comment 8 Dave Jones 2004-11-29 09:31:51 UTC
did this ever get fixed properly ?



Note You need to log in before you can comment on or make changes to this bug.