Bug 114509 - sshd fails authentication with pam_ldap
sshd fails authentication with pam_ldap
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 16:46 EST by Glen Eustace
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 20:26:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
nsswitch (1.66 KB, text/plain)
2004-01-28 16:49 EST, Glen Eustace
no flags Details
ldap.conf (764 bytes, text/plain)
2004-01-28 16:54 EST, Glen Eustace
no flags Details
system-auth (1011 bytes, text/plain)
2004-01-28 16:55 EST, Glen Eustace
no flags Details

  None (edit)
Description Glen Eustace 2004-01-28 16:46:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1)

Description of problem:
nss_ldap successfully retrieves data from MS ADS using getpwnam() which would indicate that nsswitch.conf and ldap.conf are ok.
When authconfig has setup system-auth file, sshd fails to find user.  The query being passed to LDAP is looking for NOUSER.


Version-Release number of selected component (if applicable):
nss_ldap-207-6,openssh-3.6.1p2-19

How reproducible:
Always

Steps to Reproduce:
1. Run authconfig and select LDAP
2. Attempt ssh to localhost

    

Actual Results:  Login declined, invalid user.

Additional info:
Comment 1 Glen Eustace 2004-01-28 16:49:32 EST
Created attachment 97313 [details]
nsswitch
Comment 2 Glen Eustace 2004-01-28 16:54:27 EST
Created attachment 97314 [details]
ldap.conf
Comment 3 Glen Eustace 2004-01-28 16:55:38 EST
Created attachment 97315 [details]
system-auth
Comment 4 Glen Eustace 2004-01-28 16:57:06 EST
Query send to ADS 
-------------------- 
Lightweight Directory Access Protocol 
    Message Id: 2 
    Message Type: Search Request (0x03) 
    Message Length: 104 
    Base DN: ou=Staff,ou=Clients,dc=massey,dc=ac,dc=nz 
    Scope: Subtree (0x02) 
    Dereference: Never (0x00) 
    Size Limit: 1 
    Time Limit: 0 
    Attributes Only: False 
    Filter: (&(objectclass=User)(msSFUName=NOUSER)) 
 
Comment 5 Glen Eustace 2004-01-29 20:26:39 EST
This not a bug, running sshd in debug showed that the shell for the 
user in ldap was invalid on the system running sshd. Using a user 
that has a valid shell for the system concerned works fine. 
 

Note You need to log in before you can comment on or make changes to this bug.