Bug 114528 - Installer displays inappropriate error message when exiting abnormally
Summary: Installer displays inappropriate error message when exiting abnormally
Status: CLOSED DUPLICATE of bug 113346
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-29 05:30 UTC by Dean Samuels
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dean Samuels 2004-01-29 05:30:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Anaconda displays an inappropriate error message when exiting
abnormally from an installation.  The error message is reproduceable
on a IBM Blade server with QLogic 2300 adapter installed.  Starting an
installation as normal will produce the error message "You're running
me on a live system! That's incredibly stupid.".  The problem can be
overcome by either using noprobe option and selecting qla2300 driver
manually.  Or with now USB support using the nousb option.  However,
the error message itself is not only inappropriate but also very
misleading and should not be visible in an enterprise class product.

Version-Release number of selected component (if applicable):
anaconda-7.2-68_ELAS

How reproducible:
Always

Steps to Reproduce:
1. Blade server with QLogic Fibre Card
2. Start install as normal
3. Error message appears when trying to start second stage of anaconda
    

Actual Results:  Installation exited abnormally with inappropriate
error message "You're running me on a live system! That's incredibly
stupid."

Expected Results:  Installation exited abnormally with appropriate
error message even if it is generic.

Additional info:

Comment 2 Suzanne Hillman 2004-02-02 19:39:20 UTC

*** This bug has been marked as a duplicate of 113346 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.