Bug 114532 - Kernel Compile Failed
Kernel Compile Failed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 03:36 EST by Anshul Gupta
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 15:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anshul Gupta 2004-01-29 03:36:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.23; Mac_PowerPC)

Description of problem:
While compiling kernel 2.4.24 (make modules) on RHL 9.0 I got the following 
error.

----------OUTPUT-----------------------------------
gcc -D__KERNEL__ -I/usr/src/linux-2.4.24/include -Wall -Wstrict-prototypes -
Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe 
-mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -
include /usr/src/linux-2.4.24/include/linux/modversions.h  -nostdinc -
iwithprefix include -DKBUILD_BASENAME=ipt_length  -c -o ipt_length.o 
ipt_length.c
gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc -D__KERNEL__ -
I/usr/src/linux-2.4.24/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -
fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-
boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include /usr/src/
linux-2.4.24/include/linux/modversions.h  -nostdinc -iwithprefix include -
DKBUILD_BASENAME=hgafb  -c -o hgafb.o hgafb.c
gcc: gcc: gcc: gcc: gcc: make[3]: Entering directory `/usr/src/linux-2.4.24/
drivers/ide/ppc'
gcc: gcc: gcc: gcc: gcc: gcc: gcc: gcc: make[1]: make[1]: make[2]: make[2]: 
make[2]: make[2]: make[2]: Internal error: Terminated (program cc1)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.Internal error: 
Terminated (program cc1)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.Internal error: 
Terminated (program cc1)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.Internal error: 
Terminated (program cc1)

Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.Internal error: 
Terminated (program cc1)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.Internal error: 
Terminated (program cc1)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.gcc -
D__KERNEL__ -I/usr/src/linux-2.4.24/include -Wall -Wstrict-prototypes -Wno-
trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -
mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -
include /usr/src/linux-2.4.24/include/linux/modversions.h  -nostdinc -
iwithprefix include -DKBUILD_BASENAME=nfsproc  -c -o nfsproc.o nfsproc.c

-------------END OF OUTPUT----------------------------

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make modules
2.
3.
    

Additional info:
Comment 1 Jakub Jelinek 2004-01-30 08:43:47 EST
Terminated means something or someone sent SIGTERM to the cc1 processes.
GCC doesn't send this signal to itself, so it must be something else
and doesn't look like GCC's bug.
Perhaps you're running out of memory and kernel oom handler kicks in
or something.
Comment 2 Anshul Gupta 2004-01-31 03:38:21 EST
I was connected to the machine remotely. The machine stopped responding. 
When I asked the data centre support team they told that the machine is 
continously diplaying out of memory message on the console. 

The machine has 512 MB RAM and the swap space was turned off. What do 
you think can be the problem?
Comment 3 Jakub Jelinek 2004-02-09 11:00:32 EST
Depends on how many compilations you were doing at once (ie. -jN).
Comment 4 Anshul Gupta 2004-02-09 18:00:00 EST
I have 2 CPUs and 4 virtual CPUs (due to HT), I was using -j5,
Comment 5 Anshul Gupta 2004-02-09 18:01:09 EST
I have 2 real CPUs (or 4 virtual CPUs due to hyper threading), I was using -j5.
Comment 6 Richard Henderson 2004-10-04 15:20:38 EDT
Definitely the OOM handler.  With 5 concurrent compilations, it would
be very easy to exceed 512MB.

Note You need to log in before you can comment on or make changes to this bug.