Bug 114542 - "Inconsistent extfs archive" when "entering" rpm in dir with space in name
"Inconsistent extfs archive" when "entering" rpm in dir with space in name
Status: CLOSED DUPLICATE of bug 102453
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 07:54 EST by Leonard den Ottolander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
extfs/rpm: Workaround for spaces and single quotes in the path (1.96 KB, application/octet-stream)
2004-02-17 09:48 EST, Andrew V. Samoilov
no flags Details

  None (edit)
Description Leonard den Ottolander 2004-01-29 07:54:44 EST
Description of problem:

When trying to "enter" an rpm and the directory in which the rpm is
located has a space in the name entering the rpm fails with an
"Inconsistent extfs archive".


Version-Release number of selected component (if applicable):

mc-4.6.0-6, mc-4.6.0-8.1


How reproducible:

Try entering an rpm in a directory that has a space in it's name (fe
"Fedora updates"). This will fail. Now rename the directory so it
doesn't contain a space (mv Fedora\ updates FedoraUpdates) and try again.
Comment 1 Leonard den Ottolander 2004-02-10 22:08:23 EST
This seems to be an issue with rpm:

$ rpm -qp 'a b/SysVinit-2.85-5.i386.rpm'
error: open of a failed: No such file or directory
$ rpm -qp 'a\ b/SysVinit-2.85-5.i386.rpm'
warning: a b/SysVinit-2.85-5.i386.rpm: V3 DSA signature: NOKEY, key ID
897da07a
SysVinit-2.85-5

Closing this bug as duplicate of bug #102453
Comment 2 Leonard den Ottolander 2004-02-10 22:09:06 EST

*** This bug has been marked as a duplicate of 102453 ***
Comment 3 Leonard den Ottolander 2004-02-10 22:15:10 EST
Of course this could be fixed in vfs/extfs/rpm by replacing all
occurences of $1 with a string with escaped spaces (and tabs?). Should
be an easy fix. Good idea to implement this?
Comment 4 Andrew V. Samoilov 2004-02-17 09:48:55 EST
Created attachment 97748 [details]
extfs/rpm: Workaround for spaces and single quotes in the path

vfs/ChangeLog:

	* extfs/rpm: Workaround for spaces and single quotes in the path
	name.
Comment 5 Andrew V. Samoilov 2004-02-17 10:19:18 EST
Comment on attachment 97748 [details]
extfs/rpm: Workaround for spaces and single quotes in the path

Change MIME Type to application/octet-stream
Comment 6 Red Hat Bugzilla 2006-02-21 14:00:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.