Bug 11455 - vimtutor requires vim-enhanced
Summary: vimtutor requires vim-enhanced
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-16 21:12 UTC by Miloslav Trmac
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 21:12:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miloslav Trmac 2000-05-16 21:12:46 UTC
/bin/vimtutor (probably shouldn't be in /bin anyway) assumes 'vim'.

I think it should to something like this (not tested!):

-----------------------------------------

if [ ! -z "$DISPLAY" -a -x /usr/X11R6/bin/gvim ]; then

  VIM=/usr/X11R6/bin/gvim

elif [ -x /usr/bim/vim ];

  VIM=/usr/bin/vim

elif [ -x /bin/vi ];

  VIM=/bin/vi

else

  echo "You don't have vi installed!" >&2

  exit

fi

------------------------------------

and then use '$VIM' instead of 'vim'.

Comment 1 Bernhard Rosenkraenzer 2000-08-08 10:54:18 UTC
Thanks, fixed.


Note You need to log in before you can comment on or make changes to this bug.