Bug 114564 - xemacs crashes regularly
xemacs crashes regularly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 12:03 EST by david d zuhn
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 16:28:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david d zuhn 2004-01-29 12:03:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Editing in XEmacs will regularly cause the application to vanish.  
This happens quite regularly for me, although I cannot recreate an
exact sequence of operations to cause this.  

First, I'll note that I discovered this with my own .emacs
configuration.  This is not nearly as repeatable using a clean (xemacs
-q) instance.  I've done it, but not under the debugger.  I've tried
narrowing down my own emacs config to find something in particular,
but haven't had any luck yet. 

The general operations that cause a problem are using dired on a
directory with a number of subdirectories.   Visit a subdirectory,
immediately 'q' back to the first, select another subdir, repeating
the process several times.  Eventually (often within a couple of
subdir selections), the process vanishes.

Running under a debugger, I get the following:

gdb --symbols=/usr/lib/debug/usr/bin/xemacs-21.4.14.debug  xemacs

 (gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /usr/bin/xemacs
[Thread debugging using libthread_db enabled]
[New Thread -1084927872 (LWP 10688)]
Fatal error: assertion failed, file xlwtabs.c, line 1997, *reply_width
> 0 && *reply_height > 0
 
Program received signal SIGABRT, Aborted.
[Switching to Thread -1084927872 (LWP 10688)]
0x00da1c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2


Version-Release number of selected component (if applicable):
xemacs-21.4.14-3

How reproducible:
Sometimes

Steps to Reproduce:
1. The general operations that cause a problem are using dired on a
directory with a number of subdirectories.   Visit a subdirectory,
immediately 'q' back to the first, select another subdir, repeating
the process several times.  Eventually (often within a couple of
subdir selections), the process vanishes.

Additional info:
Comment 1 david d zuhn 2004-01-29 12:20:50 EST
Additional information:

This also occurs on RHEL 3 (Update 1) (i386) with version
xemacs-21.4.13-2.ent


XEmacs thread that seems related
http://list-archive.xemacs.org/xemacs-beta/200212/msg00223.html

A Debian bug report.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=196524

Comment 2 Jens Petersen 2004-01-29 21:46:27 EST
Can you still reproduce the crashes with the latest
xemacs build in FC devel trees.
Comment 3 Jens Petersen 2004-04-01 06:28:31 EST
If you can still reproduce, can you attach your init file?
Comment 4 Ville Skyttä 2007-06-14 16:28:18 EDT
Closing due to lack of feedback, feel free to reopen if the problem persists in
active Fedora releases.

Note You need to log in before you can comment on or make changes to this bug.