Bug 114637 - Kernel upgrade problem.
Kernel upgrade problem.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
: 139800 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-30 10:10 EST by Christian Nilsson
Modified: 2013-08-05 21:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 15:19:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nilsson 2004-01-30 10:10:25 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Easy

Steps to Reproduce:
1.upgrade kernel from 2.4.9-e.24smp to 2.4.9-e.35smp
2.Reboot

  
Actual results:
When doing the upgrade with up2date yo will have a warning that it
cant find module cciss_2427.
When rebooting you will have kernel panik!

The problem is that the cciss module has changed name from cciss_2427
to cciss_2445!

Solution:
change name in /etc/modules.conf for the cciss module.
do 
mkinitrd initrd-2.4.9-e.35smp.img 2.4.9-e.35smp
add:
initrd /initrd-2.4.9-e.35smp.img 
to /etc/grub.conf
reboot!
Voila!



Expected results:


Additional info:
Comment 1 Jim Paradis 2005-12-05 15:19:16 EST
This issue is outside the scope of the current support status for RHEL2.1.  No
fix is planned.


Comment 2 Jim Paradis 2005-12-05 17:38:21 EST
Additionally, this issue should be resolved in the most recent version of the
kernel.
Comment 3 Jim Paradis 2005-12-05 17:39:37 EST
*** Bug 139800 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.