Bug 114645 - [PATCH] ucd-snmp not 64-bit clean
[PATCH] ucd-snmp not 64-bit clean
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-30 12:17 EST by Mark Langsdorf
Modified: 2010-05-06 07:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 07:08:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make ucd-snmp 64-bit clean (7.89 KB, patch)
2004-01-30 12:18 EST, Mark Langsdorf
no flags Details | Diff
test case for UCD SNMP code (171 bytes, text/plain)
2004-03-17 15:05 EST, Mark Langsdorf
no flags Details
Patch to fix leaky file descriptors (724 bytes, patch)
2004-07-07 12:15 EDT, Mark Langsdorf
no flags Details | Diff

  None (edit)
Description Mark Langsdorf 2004-01-30 12:17:37 EST
Description of problem:
ucd-snmp uses a long where it should use u32 and inadvertently 
resizes data packets on AMD64 systems.

Version-Release number of selected component (if applicable):
4.2

How reproducible:
solonow:/home/mlangsdo # rpm -q ucdsnmp
ucdsnmp-4.2.6-131
solonow:/home/mlangsdo # /etc/init.d/snmpd start
Starting snmpd                                                       
done
solonow:/home/mlangsdo # snmpget -m all localhost -c public -
d .1.3.6.1.2.1.4.20.1.1.127.0.0.1

Sending 48 bytes to 127.0.0.1:161
0000: 30 2E 02 01  00 04 06 70  75 62 6C 69  63 A0 21 02   
0......public !.
0016: 04 49 77 FC  18 02 01 00  02 01 00 30  13 30 11 
06    .Iwü.......0.0..
0032: 0D 2B 06 01  02 01 04 14  01 01 7F 00  00 01 05 
00    .+..............


Received 56 bytes from 127.0.0.1:161
0000: 30 36 02 01  00 04 06 70  75 62 6C 69  63 A2 29 02    
06.....public¢).
0016: 04 49 77 FC  18 02 01 00  02 01 00 30  1B 30 19 
06    .Iwü.......0.0..
0032: 0D 2B 06 01  02 01 04 14  01 01 7F 00  00 01 40 
08    .+............@.
0048: 7F 00 00 01  00 00 00 00                              ........

ip.ipAddrTable.ipAddrEntry.ipAdEntAddr.127.0.0.1 = IpAddress: 
127.0.0.1
solonow:/home/mlangsdo # 

Expected results:


Additional info:
Comment 1 Mark Langsdorf 2004-01-30 12:18:15 EST
Created attachment 97369 [details]
patch to make ucd-snmp 64-bit clean
Comment 2 Phil Knirsch 2004-02-04 10:35:40 EST
Patch looks good, including it in latest rawhide build.

Read ya, Phil
Comment 3 Mark Langsdorf 2004-03-17 15:05:50 EST
Created attachment 98612 [details]
test case for UCD SNMP code

We found additional failures under further testing.  Please run this test case
for 24 hours without failure - it should flush out the bugs.

Compile with g++
Comment 4 Phil Knirsch 2004-04-15 08:21:50 EDT
Actually this is all about net-snmp, not ucd-snmp. :D

Changing the component to the proper one.

Read ya, Phil
Comment 5 Phil Knirsch 2004-07-07 11:57:47 EDT
Included patch in latest errata version for Red Hat Enterprise Linux 3
Quarterly Update 3.

Read ya, Phil
Comment 6 Mark Langsdorf 2004-07-07 12:15:28 EDT
Created attachment 101685 [details]
Patch to fix leaky file descriptors
Comment 7 Mark Langsdorf 2004-07-07 12:16:17 EDT
We found there were leaky file descriptors in all architectures.  
I've included the patch to fix the bug.  Sorry if the formatting got 
screwed by my idiot computer.
Comment 11 Jan Safranek 2010-05-06 07:08:08 EDT
According to changelog, this bug is fixed since net-snmp-5.0.9-2.30E.5 and Phil just forgot to close it -> closing.

Note You need to log in before you can comment on or make changes to this bug.