Bug 1146581 - Typing unicode chars to keyboard layout selection box cause crash
Summary: Typing unicode chars to keyboard layout selection box cause crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1151111 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-25 14:44 UTC by Miro Hrončok
Modified: 2014-10-20 23:01 UTC (History)
5 users (show)

Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 23:01:52 UTC
Type: Bug


Attachments (Terms of Use)
anaconda-tb (2.81 MB, text/plain)
2014-09-25 15:20 UTC, David Shea
no flags Details

Description Miro Hrončok 2014-09-25 14:44:52 UTC
Description of problem:
When I type "češ" to keyboard selection box, Anaconda crashes. The resulting "Report bug" dialog is unresponsive and generates more dialogs.

Version-Release number of selected component (if applicable):
Fedora 21 Alpha.

How reproducible:
Always.

Steps to Reproduce:
1. Select Install Fedora
2. Select Czech locale
3. Try to change the keyboard layout, in the filter input field type češ

Actual results:
Crash

Expected results:
No crash, display expected results (such as Čeština)

Additional info:
Recorded here: https://www.youtube.com/watch?v=M_a0GCZQjfc

Comment 1 David Shea 2014-09-25 15:20:49 UTC
Created attachment 941138 [details]
anaconda-tb

You can always switch to a text console with Ctrl-Alt-F2 and get the anaconda-tb-* file out of /tmp. Attaching one that I just reproduced. That's pretty weird, though, it seemed to get stuck in a loop opening exception windows. This also only appears to happen in the live environment.

anaconda 21.48.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 851, in <genexpr>
    return all(word in str2 for word in str1_words)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 851, in have_word_match
    return all(word in str2 for word in str1_words)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/keyboard.py", line 84, in matches_entry
    return have_word_match(entry_text, eng_value) or have_word_match(entry_text, xlated_value) \
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 0: ordinal not in range(128)

Local variables in innermost frame:
.0: <listiterator object at 0x7f6106fdc210>
str2: francouzština (francouzské (guinea))
word: č

Comment 2 David Shea 2014-10-09 15:39:05 UTC
*** Bug 1151111 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2014-10-15 13:07:47 UTC
anaconda-21.48.10-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.10-1.fc21

Comment 4 Fedora Update System 2014-10-16 17:18:31 UTC
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12944/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-10-20 23:01:52 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.