Bug 114660 - Conf.py:593:__delitem__:KeyError: switch/hubTraceback (most recent call last):
Conf.py:593:__delitem__:KeyError: switch/hubTraceback (most recent call last):
Status: CLOSED DUPLICATE of bug 108918
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2004-01-30 15:04 EST by Giri Raju
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Giri Raju 2004-01-30 15:04:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Component: redhat-config-network
Version: 1.2.59
Summary: TB523bdfc2 Conf.py:593:__delitem__:KeyError: switch/hub
Traceback (most recent call last):
line 747, in on_applyButton_clicked
line 341, in save
line 373, in saveProfiles
line 362, in save
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 593, in
    del self.vars[varname]
KeyError: switch/hub

Local variables in innermost frame:
varname: switch/hub
self: <rhpl.Conf.ConfFHosts instance at 0x881811c>

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.try to save at new work config.

Additional info:
Comment 1 Harald Hoyer 2004-02-02 03:34:03 EST
please attach your /etc/hosts

*** This bug has been marked as a duplicate of 108918 ***
Comment 2 Giri Raju 2004-02-02 11:39:36 EST
here is /etc/hosts :

# Do not remove the following line, or various programs
# that require network functionality will fail.		TRINETRA localhost.localdomain localhost
Comment 3 Giri Raju 2004-02-02 11:41:01 EST
Hi Harald

Ps. Advise me how do i resolve this issue, i am also not able to 
access internet from my linux box which i used to do till friday, 
some thing freeky going on my box.
Comment 4 Harald Hoyer 2004-02-03 08:32:28 EST
ah... do not name your profile with a slash "/" :)
rm -fr /etc/sysconfig/networking/profiles/[^d]*
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.