Bug 114672 - [PATCH] Fix warning when trying to remove VMware lock files
[PATCH] Fix warning when trying to remove VMware lock files
Status: CLOSED DUPLICATE of bug 110265
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-30 16:58 EST by Felipe Alfaro Solana
Modified: 2014-03-16 22:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix warning when trying to remove VMware lock files (343 bytes, patch)
2004-01-30 17:02 EST, Felipe Alfaro Solana
no flags Details | Diff

  None (edit)
Description Felipe Alfaro Solana 2004-01-30 16:58:55 EST
Description of problem:
-----------------------
This bug report is intended as a placeholder to store patches for
inclusion in future releases of initscripts.

Currently, I've got one patch against initscripts to fix a warning
during boot when trying to remove lock files for VMWare.

Version-Release number of selected component (if applicable):
7.44-1

How reproducible:
As long as initscripts is mantained

Steps to Reproduce:
N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
Until a CVS server is available for us, I think we should keep track
of patches and ideas under this bug entry. However, if I'm wrong,
please feel free to close this bug report.
Comment 1 Felipe Alfaro Solana 2004-01-30 17:02:47 EST
Created attachment 97378 [details]
Fix warning when trying to remove VMware lock files

This fixes the warning that is shown during boot when rc.sysinit tries to
remove VMware lock files. However, VMware organizes locks by user, then by PID
and thus, what we're trying to remove is a directory and not a file.

For example:

/var/run/vmware
    |
    --- user1
	|
	--- 12345
Comment 2 Bill Nottingham 2004-01-30 17:08:01 EST
Why not add the 'Patch' keyword to such bugs instead?
Comment 3 Felipe Alfaro Solana 2004-01-30 17:18:12 EST
Better now? 
Comment 4 Bill Nottingham 2004-01-30 17:20:33 EST
No, what I'm saying is rather than have one placeholder bug which can
never be closed, to just add the patch *keyword* (see:
https://bugzilla.redhat.com/bugzilla/describekeywords.cgi) to each bug
that has a patch.
Comment 5 Leonard den Ottolander 2004-02-05 09:23:17 EST
Bug #110265 seems to be a duplicate of this one (or the other way round).
Comment 6 Bill Nottingham 2004-02-05 10:19:52 EST

*** This bug has been marked as a duplicate of 110265 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:01:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.